summaryrefslogtreecommitdiffstats
path: root/tests/run-make/exit-code
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/exit-code
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/exit-code')
-rw-r--r--tests/run-make/exit-code/Makefile12
-rw-r--r--tests/run-make/exit-code/compile-error.rs3
-rw-r--r--tests/run-make/exit-code/lint-failure.rs6
-rw-r--r--tests/run-make/exit-code/success.rs4
4 files changed, 25 insertions, 0 deletions
diff --git a/tests/run-make/exit-code/Makefile b/tests/run-make/exit-code/Makefile
new file mode 100644
index 000000000..6458b7168
--- /dev/null
+++ b/tests/run-make/exit-code/Makefile
@@ -0,0 +1,12 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) success.rs; [ $$? -eq 0 ]
+ $(RUSTC) --invalid-arg-foo; [ $$? -eq 1 ]
+ $(RUSTC) compile-error.rs; [ $$? -eq 1 ]
+ $(RUSTC) -Ztreat-err-as-bug compile-error.rs; [ $$? -eq 101 ]
+ $(RUSTDOC) -o $(TMPDIR)/exit-code success.rs; [ $$? -eq 0 ]
+ $(RUSTDOC) --invalid-arg-foo; [ $$? -eq 1 ]
+ $(RUSTDOC) compile-error.rs; [ $$? -eq 1 ]
+ $(RUSTDOC) lint-failure.rs; [ $$? -eq 1 ]
diff --git a/tests/run-make/exit-code/compile-error.rs b/tests/run-make/exit-code/compile-error.rs
new file mode 100644
index 000000000..a96c19760
--- /dev/null
+++ b/tests/run-make/exit-code/compile-error.rs
@@ -0,0 +1,3 @@
+fn main() {
+ compile_error!("kaboom");
+}
diff --git a/tests/run-make/exit-code/lint-failure.rs b/tests/run-make/exit-code/lint-failure.rs
new file mode 100644
index 000000000..df876ec23
--- /dev/null
+++ b/tests/run-make/exit-code/lint-failure.rs
@@ -0,0 +1,6 @@
+#![deny(broken_intra_doc_links)]
+
+/// [intradoc::failure]
+pub fn main() {
+ println!("Hello, world!");
+}
diff --git a/tests/run-make/exit-code/success.rs b/tests/run-make/exit-code/success.rs
new file mode 100644
index 000000000..55b8e42b6
--- /dev/null
+++ b/tests/run-make/exit-code/success.rs
@@ -0,0 +1,4 @@
+/// Main function
+fn main() {
+ println!("Hello, world!");
+}