summaryrefslogtreecommitdiffstats
path: root/tests/run-make/intrinsic-unreachable/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/intrinsic-unreachable/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/intrinsic-unreachable/Makefile')
-rw-r--r--tests/run-make/intrinsic-unreachable/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/intrinsic-unreachable/Makefile b/tests/run-make/intrinsic-unreachable/Makefile
new file mode 100644
index 000000000..ff9cc5709
--- /dev/null
+++ b/tests/run-make/intrinsic-unreachable/Makefile
@@ -0,0 +1,12 @@
+include ../tools.mk
+
+# needs-asm-support
+# ignore-windows-msvc
+#
+# Because of Windows exception handling, the code is not necessarily any shorter.
+# https://github.com/llvm-mirror/llvm/commit/64b2297786f7fd6f5fa24cdd4db0298fbf211466
+
+all:
+ $(RUSTC) -O --emit asm exit-ret.rs
+ $(RUSTC) -O --emit asm exit-unreachable.rs
+ test `wc -l < $(TMPDIR)/exit-unreachable.s` -lt `wc -l < $(TMPDIR)/exit-ret.s`