summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-20626
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/issue-20626
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/issue-20626')
-rw-r--r--tests/run-make/issue-20626/Makefile9
-rw-r--r--tests/run-make/issue-20626/foo.rs13
2 files changed, 22 insertions, 0 deletions
diff --git a/tests/run-make/issue-20626/Makefile b/tests/run-make/issue-20626/Makefile
new file mode 100644
index 000000000..63eee910a
--- /dev/null
+++ b/tests/run-make/issue-20626/Makefile
@@ -0,0 +1,9 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# Test output to be four
+# The original error only occurred when printing, not when comparing using assert!
+
+all:
+ $(RUSTC) foo.rs -O
+ [ `$(call RUN,foo)` = "4" ]
diff --git a/tests/run-make/issue-20626/foo.rs b/tests/run-make/issue-20626/foo.rs
new file mode 100644
index 000000000..a474e234e
--- /dev/null
+++ b/tests/run-make/issue-20626/foo.rs
@@ -0,0 +1,13 @@
+fn identity(a: &u32) -> &u32 { a }
+
+fn print_foo(f: &fn(&u32) -> &u32, x: &u32) {
+ print!("{}", (*f)(x));
+}
+
+fn main() {
+ let x = &4;
+ let f: fn(&u32) -> &u32 = identity;
+
+ // Didn't print 4 on optimized builds
+ print_foo(&f, x);
+}