summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-37893
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/issue-37893
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/issue-37893')
-rw-r--r--tests/run-make/issue-37893/Makefile5
-rw-r--r--tests/run-make/issue-37893/a.rs2
-rw-r--r--tests/run-make/issue-37893/b.rs2
-rw-r--r--tests/run-make/issue-37893/c.rs3
4 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/issue-37893/Makefile b/tests/run-make/issue-37893/Makefile
new file mode 100644
index 000000000..44e4a321a
--- /dev/null
+++ b/tests/run-make/issue-37893/Makefile
@@ -0,0 +1,5 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) a.rs && $(RUSTC) b.rs && $(RUSTC) c.rs
diff --git a/tests/run-make/issue-37893/a.rs b/tests/run-make/issue-37893/a.rs
new file mode 100644
index 000000000..b5dffac3f
--- /dev/null
+++ b/tests/run-make/issue-37893/a.rs
@@ -0,0 +1,2 @@
+#![allow(unused)]
+#![crate_type = "proc-macro"]
diff --git a/tests/run-make/issue-37893/b.rs b/tests/run-make/issue-37893/b.rs
new file mode 100644
index 000000000..355d2b165
--- /dev/null
+++ b/tests/run-make/issue-37893/b.rs
@@ -0,0 +1,2 @@
+#![crate_type = "lib"]
+#[macro_use] extern crate a;
diff --git a/tests/run-make/issue-37893/c.rs b/tests/run-make/issue-37893/c.rs
new file mode 100644
index 000000000..b9c215572
--- /dev/null
+++ b/tests/run-make/issue-37893/c.rs
@@ -0,0 +1,3 @@
+#![crate_type = "staticlib"]
+extern crate b;
+extern crate a;