summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-40535/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/issue-40535/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/issue-40535/Makefile')
-rw-r--r--tests/run-make/issue-40535/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/run-make/issue-40535/Makefile b/tests/run-make/issue-40535/Makefile
new file mode 100644
index 000000000..155c88252
--- /dev/null
+++ b/tests/run-make/issue-40535/Makefile
@@ -0,0 +1,13 @@
+include ../tools.mk
+
+# The ICE occurred in the following situation:
+# * `foo` declares `extern crate bar, baz`, depends only on `bar` (forgetting `baz` in `Cargo.toml`)
+# * `bar` declares and depends on `extern crate baz`
+# * All crates built in metadata-only mode (`cargo check`)
+all:
+ # cc https://github.com/rust-lang/rust/issues/40623
+ $(RUSTC) baz.rs --emit=metadata
+ $(RUSTC) bar.rs --emit=metadata --extern baz=$(TMPDIR)/libbaz.rmeta
+ $(RUSTC) foo.rs --emit=metadata --extern bar=$(TMPDIR)/libbar.rmeta 2>&1 | \
+ $(CGREP) -v "unexpectedly panicked"
+ # ^ Succeeds if it doesn't find the ICE message