summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-47384
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /tests/run-make/issue-47384
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/issue-47384')
-rw-r--r--tests/run-make/issue-47384/Makefile12
-rw-r--r--tests/run-make/issue-47384/lib.rs12
-rw-r--r--tests/run-make/issue-47384/linker.ld7
-rw-r--r--tests/run-make/issue-47384/main.rs1
4 files changed, 32 insertions, 0 deletions
diff --git a/tests/run-make/issue-47384/Makefile b/tests/run-make/issue-47384/Makefile
new file mode 100644
index 000000000..0aadf6c88
--- /dev/null
+++ b/tests/run-make/issue-47384/Makefile
@@ -0,0 +1,12 @@
+include ../../run-make-fulldeps/tools.mk
+
+# only-linux
+# ignore-cross-compile
+
+all: main.rs
+ $(RUSTC) --crate-type lib lib.rs
+ $(RUSTC) --crate-type cdylib -Clink-args="-Tlinker.ld" main.rs
+ # Ensure `#[used]` and `KEEP`-ed section is there
+ objdump -s -j".static" $(TMPDIR)/libmain.so
+ # Ensure `#[no_mangle]` symbol is there
+ nm $(TMPDIR)/libmain.so | $(CGREP) bar
diff --git a/tests/run-make/issue-47384/lib.rs b/tests/run-make/issue-47384/lib.rs
new file mode 100644
index 000000000..99508bcda
--- /dev/null
+++ b/tests/run-make/issue-47384/lib.rs
@@ -0,0 +1,12 @@
+mod foo {
+ #[link_section = ".rodata.STATIC"]
+ #[used]
+ static STATIC: [u32; 10] = [1; 10];
+}
+
+mod bar {
+ #[no_mangle]
+ extern "C" fn bar() -> i32 {
+ 0
+ }
+}
diff --git a/tests/run-make/issue-47384/linker.ld b/tests/run-make/issue-47384/linker.ld
new file mode 100644
index 000000000..2e70acab3
--- /dev/null
+++ b/tests/run-make/issue-47384/linker.ld
@@ -0,0 +1,7 @@
+SECTIONS
+{
+ .static : ALIGN(4)
+ {
+ KEEP(*(.rodata.STATIC));
+ }
+}
diff --git a/tests/run-make/issue-47384/main.rs b/tests/run-make/issue-47384/main.rs
new file mode 100644
index 000000000..025726325
--- /dev/null
+++ b/tests/run-make/issue-47384/main.rs
@@ -0,0 +1 @@
+extern crate lib;