summaryrefslogtreecommitdiffstats
path: root/tests/run-make/libs-through-symlinks/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/libs-through-symlinks/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/libs-through-symlinks/Makefile')
-rw-r--r--tests/run-make/libs-through-symlinks/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/libs-through-symlinks/Makefile b/tests/run-make/libs-through-symlinks/Makefile
new file mode 100644
index 000000000..592eae663
--- /dev/null
+++ b/tests/run-make/libs-through-symlinks/Makefile
@@ -0,0 +1,12 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-windows
+
+NAME := $(shell $(RUSTC) --print file-names foo.rs)
+
+all:
+ mkdir -p $(TMPDIR)/outdir
+ $(RUSTC) foo.rs -o $(TMPDIR)/outdir/$(NAME)
+ ln -nsf outdir/$(NAME) $(TMPDIR)
+ RUSTC_LOG=rustc_metadata::loader $(RUSTC) bar.rs