summaryrefslogtreecommitdiffstats
path: root/tests/run-make/link-cfg/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/link-cfg/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/link-cfg/Makefile')
-rw-r--r--tests/run-make/link-cfg/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/run-make/link-cfg/Makefile b/tests/run-make/link-cfg/Makefile
new file mode 100644
index 000000000..a40997011
--- /dev/null
+++ b/tests/run-make/link-cfg/Makefile
@@ -0,0 +1,23 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: $(call DYLIB,return1) $(call DYLIB,return2) $(call NATIVE_STATICLIB,return3)
+ ls $(TMPDIR)
+ $(BARE_RUSTC) --print cfg --target x86_64-unknown-linux-musl | $(CGREP) crt-static
+
+ $(RUSTC) no-deps.rs --cfg foo
+ $(call RUN,no-deps)
+ $(RUSTC) no-deps.rs --cfg bar
+ $(call RUN,no-deps)
+
+ $(RUSTC) dep.rs
+ $(RUSTC) with-deps.rs --cfg foo
+ $(call RUN,with-deps)
+ $(RUSTC) with-deps.rs --cfg bar
+ $(call RUN,with-deps)
+
+ $(RUSTC) dep-with-staticlib.rs
+ $(RUSTC) with-staticlib-deps.rs --cfg foo
+ $(call RUN,with-staticlib-deps)
+ $(RUSTC) with-staticlib-deps.rs --cfg bar
+ $(call RUN,with-staticlib-deps)