summaryrefslogtreecommitdiffstats
path: root/tests/run-make/lto-smoke-c/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/lto-smoke-c/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/lto-smoke-c/Makefile')
-rw-r--r--tests/run-make/lto-smoke-c/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/lto-smoke-c/Makefile b/tests/run-make/lto-smoke-c/Makefile
new file mode 100644
index 000000000..f1ba3d95d
--- /dev/null
+++ b/tests/run-make/lto-smoke-c/Makefile
@@ -0,0 +1,12 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# Apparently older versions of GCC segfault if -g is passed...
+CC := $(CC:-g=)
+
+all:
+ $(RUSTC) foo.rs -C lto
+ $(CC) bar.c $(call STATICLIB,foo) \
+ $(call OUT_EXE,bar) \
+ $(EXTRACFLAGS) $(EXTRACXXFLAGS)
+ $(call RUN,bar)