summaryrefslogtreecommitdiffstats
path: root/tests/run-make/lto-smoke/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/lto-smoke/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/lto-smoke/Makefile')
-rw-r--r--tests/run-make/lto-smoke/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/run-make/lto-smoke/Makefile b/tests/run-make/lto-smoke/Makefile
new file mode 100644
index 000000000..13a09fce7
--- /dev/null
+++ b/tests/run-make/lto-smoke/Makefile
@@ -0,0 +1,31 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: noparam bool_true bool_false thin fat
+
+noparam:
+ $(RUSTC) lib.rs
+ $(RUSTC) main.rs -C lto
+ $(call RUN,main)
+
+bool_true:
+ $(RUSTC) lib.rs
+ $(RUSTC) main.rs -C lto=yes
+ $(call RUN,main)
+
+
+bool_false:
+ $(RUSTC) lib.rs
+ $(RUSTC) main.rs -C lto=off
+ $(call RUN,main)
+
+thin:
+ $(RUSTC) lib.rs
+ $(RUSTC) main.rs -C lto=thin
+ $(call RUN,main)
+
+fat:
+ $(RUSTC) lib.rs
+ $(RUSTC) main.rs -C lto=fat
+ $(call RUN,main)
+