summaryrefslogtreecommitdiffstats
path: root/tests/run-make/mingw-export-call-convention/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/mingw-export-call-convention/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/mingw-export-call-convention/Makefile')
-rw-r--r--tests/run-make/mingw-export-call-convention/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/run-make/mingw-export-call-convention/Makefile b/tests/run-make/mingw-export-call-convention/Makefile
new file mode 100644
index 000000000..4a60059cc
--- /dev/null
+++ b/tests/run-make/mingw-export-call-convention/Makefile
@@ -0,0 +1,9 @@
+include ../tools.mk
+
+# only-windows-gnu
+
+all:
+ $(RUSTC) foo.rs
+ # FIXME: we should make sure __stdcall calling convention is used here
+ # but that only works with LLD right now
+ nm -g "$(call IMPLIB,foo)" | $(CGREP) bar