summaryrefslogtreecommitdiffstats
path: root/tests/run-make/mixing-libs
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:59:24 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:59:24 +0000
commit023939b627b7dc93b01471f7d41fb8553ddb4ffa (patch)
tree60fc59477c605c72b0a1051409062ddecc43f877 /tests/run-make/mixing-libs
parentAdding debian version 1.72.1+dfsg1-1. (diff)
downloadrustc-023939b627b7dc93b01471f7d41fb8553ddb4ffa.tar.xz
rustc-023939b627b7dc93b01471f7d41fb8553ddb4ffa.zip
Merging upstream version 1.73.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/mixing-libs')
-rw-r--r--tests/run-make/mixing-libs/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/tests/run-make/mixing-libs/Makefile b/tests/run-make/mixing-libs/Makefile
index e8262b284..459db0dfd 100644
--- a/tests/run-make/mixing-libs/Makefile
+++ b/tests/run-make/mixing-libs/Makefile
@@ -2,9 +2,7 @@
include ../tools.mk
all:
- $(RUSTC) rlib.rs
- $(RUSTC) dylib.rs
- $(RUSTC) rlib.rs --crate-type=dylib
- $(RUSTC) dylib.rs
- $(call REMOVE_DYLIBS,rlib)
+ $(RUSTC) rlib.rs --crate-type=rlib --crate-type=dylib
+ $(RUSTC) dylib.rs # no -Cprefer-dynamic so statically linking librlib.rlib
+ $(call REMOVE_DYLIBS,rlib) # remove librlib.so to test that prog.rs doesn't get confused about the removed dylib version of librlib
$(RUSTC) prog.rs && exit 1 || exit 0