summaryrefslogtreecommitdiffstats
path: root/tests/run-make/no-duplicate-libs/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/no-duplicate-libs/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/no-duplicate-libs/Makefile')
-rw-r--r--tests/run-make/no-duplicate-libs/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/run-make/no-duplicate-libs/Makefile b/tests/run-make/no-duplicate-libs/Makefile
new file mode 100644
index 000000000..4be8c0262
--- /dev/null
+++ b/tests/run-make/no-duplicate-libs/Makefile
@@ -0,0 +1,11 @@
+# ignore-cross-compile
+include ../tools.mk
+
+ifdef IS_MSVC
+# FIXME(#27979)
+all:
+else
+all: $(call STATICLIB,foo) $(call STATICLIB,bar)
+ $(RUSTC) main.rs
+ $(call RUN,main)
+endif