summaryrefslogtreecommitdiffstats
path: root/tests/run-make/overwrite-input/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
commitef24de24a82fe681581cc130f342363c47c0969a (patch)
tree0d494f7e1a38b95c92426f58fe6eaa877303a86c /tests/run-make/overwrite-input/Makefile
parentReleasing progress-linux version 1.74.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-ef24de24a82fe681581cc130f342363c47c0969a.tar.xz
rustc-ef24de24a82fe681581cc130f342363c47c0969a.zip
Merging upstream version 1.75.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--tests/run-make/overwrite-input/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/tests/run-make/overwrite-input/Makefile b/tests/run-make/overwrite-input/Makefile
index c62b5aab1..721bf62b2 100644
--- a/tests/run-make/overwrite-input/Makefile
+++ b/tests/run-make/overwrite-input/Makefile
@@ -3,11 +3,5 @@ include ../tools.mk
all:
$(RUSTC) main.rs -o main.rs 2> $(TMPDIR)/file.stderr || echo "failed successfully"
$(RUSTC) main.rs -o . 2> $(TMPDIR)/folder.stderr || echo "failed successfully"
-
-ifdef RUSTC_BLESS_TEST
- cp "$(TMPDIR)"/file.stderr file.stderr
- cp "$(TMPDIR)"/folder.stderr folder.stderr
-else
- $(DIFF) file.stderr "$(TMPDIR)"/file.stderr
- $(DIFF) folder.stderr "$(TMPDIR)"/folder.stderr
-endif
+ $(RUSTC_TEST_OP) "$(TMPDIR)"/file.stderr file.stderr
+ $(RUSTC_TEST_OP) "$(TMPDIR)"/folder.stderr folder.stderr