summaryrefslogtreecommitdiffstats
path: root/tests/run-make/pgo-gen-no-imp-symbols/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/pgo-gen-no-imp-symbols/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/pgo-gen-no-imp-symbols/Makefile')
-rw-r--r--tests/run-make/pgo-gen-no-imp-symbols/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/tests/run-make/pgo-gen-no-imp-symbols/Makefile b/tests/run-make/pgo-gen-no-imp-symbols/Makefile
new file mode 100644
index 000000000..7f72b11b6
--- /dev/null
+++ b/tests/run-make/pgo-gen-no-imp-symbols/Makefile
@@ -0,0 +1,13 @@
+# needs-profiler-support
+
+include ../tools.mk
+
+COMPILE_FLAGS=-O -Ccodegen-units=1 -Cprofile-generate="$(TMPDIR)"
+
+all:
+ $(RUSTC) $(COMPILE_FLAGS) --emit=llvm-ir test.rs
+ # We expect symbols starting with "__llvm_profile_".
+ $(CGREP) "__llvm_profile_" < $(TMPDIR)/test.ll
+ # We do NOT expect the "__imp_" version of these symbols.
+ $(CGREP) -v "__imp___llvm_profile_" < $(TMPDIR)/test.ll # 64 bit
+ $(CGREP) -v "__imp____llvm_profile_" < $(TMPDIR)/test.ll # 32 bit