summaryrefslogtreecommitdiffstats
path: root/tests/run-make/pointer-auth-link-with-c
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
commit837b550238aa671a591ccf282dddeab29cadb206 (patch)
tree914b6b8862bace72bd3245ca184d374b08d8a672 /tests/run-make/pointer-auth-link-with-c
parentAdding debian version 1.70.0+dfsg2-1. (diff)
downloadrustc-837b550238aa671a591ccf282dddeab29cadb206.tar.xz
rustc-837b550238aa671a591ccf282dddeab29cadb206.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/pointer-auth-link-with-c')
-rw-r--r--tests/run-make/pointer-auth-link-with-c/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/run-make/pointer-auth-link-with-c/Makefile b/tests/run-make/pointer-auth-link-with-c/Makefile
index 7acea0380..dffbd3035 100644
--- a/tests/run-make/pointer-auth-link-with-c/Makefile
+++ b/tests/run-make/pointer-auth-link-with-c/Makefile
@@ -5,10 +5,10 @@ include ../tools.mk
all:
$(COMPILE_OBJ) $(TMPDIR)/test.o test.c
$(AR) rcs $(TMPDIR)/libtest.a $(TMPDIR)/test.o
- $(RUSTC) -Z branch-protection=bti,pac-ret,leaf test.rs
+ $(RUSTC) --target $(TARGET) -Z branch-protection=bti,pac-ret,leaf test.rs
$(call RUN,test)
$(COMPILE_OBJ) $(TMPDIR)/test.o test.c -mbranch-protection=bti+pac-ret+leaf
$(AR) rcs $(TMPDIR)/libtest.a $(TMPDIR)/test.o
- $(RUSTC) -Z branch-protection=bti,pac-ret,leaf test.rs
+ $(RUSTC) --target $(TARGET) -Z branch-protection=bti,pac-ret,leaf test.rs
$(call RUN,test)