summaryrefslogtreecommitdiffstats
path: root/tests/run-make/pointer-auth-link-with-c
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/pointer-auth-link-with-c
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/pointer-auth-link-with-c')
-rw-r--r--tests/run-make/pointer-auth-link-with-c/Makefile14
-rw-r--r--tests/run-make/pointer-auth-link-with-c/test.c1
-rw-r--r--tests/run-make/pointer-auth-link-with-c/test.rs8
3 files changed, 23 insertions, 0 deletions
diff --git a/tests/run-make/pointer-auth-link-with-c/Makefile b/tests/run-make/pointer-auth-link-with-c/Makefile
new file mode 100644
index 000000000..7acea0380
--- /dev/null
+++ b/tests/run-make/pointer-auth-link-with-c/Makefile
@@ -0,0 +1,14 @@
+include ../tools.mk
+
+# only-aarch64
+
+all:
+ $(COMPILE_OBJ) $(TMPDIR)/test.o test.c
+ $(AR) rcs $(TMPDIR)/libtest.a $(TMPDIR)/test.o
+ $(RUSTC) -Z branch-protection=bti,pac-ret,leaf test.rs
+ $(call RUN,test)
+
+ $(COMPILE_OBJ) $(TMPDIR)/test.o test.c -mbranch-protection=bti+pac-ret+leaf
+ $(AR) rcs $(TMPDIR)/libtest.a $(TMPDIR)/test.o
+ $(RUSTC) -Z branch-protection=bti,pac-ret,leaf test.rs
+ $(call RUN,test)
diff --git a/tests/run-make/pointer-auth-link-with-c/test.c b/tests/run-make/pointer-auth-link-with-c/test.c
new file mode 100644
index 000000000..9fe07f82f
--- /dev/null
+++ b/tests/run-make/pointer-auth-link-with-c/test.c
@@ -0,0 +1 @@
+int foo() { return 0; }
diff --git a/tests/run-make/pointer-auth-link-with-c/test.rs b/tests/run-make/pointer-auth-link-with-c/test.rs
new file mode 100644
index 000000000..615ad0aeb
--- /dev/null
+++ b/tests/run-make/pointer-auth-link-with-c/test.rs
@@ -0,0 +1,8 @@
+#[link(name = "test")]
+extern "C" {
+ fn foo() -> i32;
+}
+
+fn main() {
+ unsafe {foo();}
+}