summaryrefslogtreecommitdiffstats
path: root/tests/run-make/prefer-rlib/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/prefer-rlib/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/prefer-rlib/Makefile')
-rw-r--r--tests/run-make/prefer-rlib/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/run-make/prefer-rlib/Makefile b/tests/run-make/prefer-rlib/Makefile
new file mode 100644
index 000000000..2e86b9c1d
--- /dev/null
+++ b/tests/run-make/prefer-rlib/Makefile
@@ -0,0 +1,9 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) bar.rs --crate-type=dylib --crate-type=rlib
+ ls $(TMPDIR)/$(call RLIB_GLOB,bar)
+ $(RUSTC) foo.rs
+ rm $(TMPDIR)/*bar*
+ $(call RUN,foo)