summaryrefslogtreecommitdiffstats
path: root/tests/run-make/print-cfg/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/print-cfg/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/print-cfg/Makefile')
-rw-r--r--tests/run-make/print-cfg/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/run-make/print-cfg/Makefile b/tests/run-make/print-cfg/Makefile
new file mode 100644
index 000000000..126f5768c
--- /dev/null
+++ b/tests/run-make/print-cfg/Makefile
@@ -0,0 +1,20 @@
+# needs-llvm-components: x86 arm
+
+include ../tools.mk
+
+all: default
+ $(RUSTC) --target x86_64-pc-windows-gnu --print cfg | $(CGREP) windows
+ $(RUSTC) --target x86_64-pc-windows-gnu --print cfg | $(CGREP) x86_64
+ $(RUSTC) --target i686-pc-windows-msvc --print cfg | $(CGREP) msvc
+ $(RUSTC) --target i686-apple-darwin --print cfg | $(CGREP) macos
+ $(RUSTC) --target i686-unknown-linux-gnu --print cfg | $(CGREP) gnu
+ $(RUSTC) --target arm-unknown-linux-gnueabihf --print cfg | $(CGREP) target_abi=
+ $(RUSTC) --target arm-unknown-linux-gnueabihf --print cfg | $(CGREP) eabihf
+
+ifdef IS_WINDOWS
+default:
+ $(RUSTC) --print cfg | $(CGREP) windows
+else
+default:
+ $(RUSTC) --print cfg | $(CGREP) unix
+endif