summaryrefslogtreecommitdiffstats
path: root/tests/run-make/prune-link-args/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/prune-link-args/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/prune-link-args/Makefile')
-rw-r--r--tests/run-make/prune-link-args/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/run-make/prune-link-args/Makefile b/tests/run-make/prune-link-args/Makefile
new file mode 100644
index 000000000..c21ba6ace
--- /dev/null
+++ b/tests/run-make/prune-link-args/Makefile
@@ -0,0 +1,10 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-windows
+
+# Notice the space in the end, this emulates the output of pkg-config
+RUSTC_FLAGS = -C link-args="-lc "
+
+all:
+ $(RUSTC) $(RUSTC_FLAGS) empty.rs