summaryrefslogtreecommitdiffstats
path: root/tests/run-make/redundant-libs/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/redundant-libs/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/redundant-libs/Makefile')
-rw-r--r--tests/run-make/redundant-libs/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/tests/run-make/redundant-libs/Makefile b/tests/run-make/redundant-libs/Makefile
new file mode 100644
index 000000000..0a48b2b28
--- /dev/null
+++ b/tests/run-make/redundant-libs/Makefile
@@ -0,0 +1,24 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-windows-msvc
+
+# rustc will remove one of the two redundant references to foo below. Depending
+# on which one gets removed, we'll get a linker error on SOME platforms (like
+# Linux). On these platforms, when a library is referenced, the linker will
+# only pull in the symbols needed _at that point in time_. If a later library
+# depends on additional symbols from the library, they will not have been pulled
+# in, and you'll get undefined symbols errors.
+#
+# So in this example, we need to ensure that rustc keeps the _later_ reference
+# to foo, and not the former one.
+RUSTC_FLAGS = \
+ -l static=bar \
+ -l foo \
+ -l static=baz \
+ -l foo \
+ --print link-args
+
+all: $(call DYLIB,foo) $(call STATICLIB,bar) $(call STATICLIB,baz)
+ $(RUSTC) $(RUSTC_FLAGS) main.rs
+ $(call RUN,main)