summaryrefslogtreecommitdiffstats
path: root/tests/run-make/relro-levels/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/relro-levels/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/relro-levels/Makefile')
-rw-r--r--tests/run-make/relro-levels/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/run-make/relro-levels/Makefile b/tests/run-make/relro-levels/Makefile
new file mode 100644
index 000000000..e0402f59f
--- /dev/null
+++ b/tests/run-make/relro-levels/Makefile
@@ -0,0 +1,22 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# only-linux
+#
+# This tests the different -Zrelro-level values, and makes sure that they work properly.
+
+all:
+ # Ensure that binaries built with the full relro level links them with both
+ # RELRO and BIND_NOW for doing eager symbol resolving.
+ $(RUSTC) -Zrelro-level=full hello.rs
+ readelf -l $(TMPDIR)/hello | grep -q GNU_RELRO
+ readelf -d $(TMPDIR)/hello | grep -q BIND_NOW
+
+ $(RUSTC) -Zrelro-level=partial hello.rs
+ readelf -l $(TMPDIR)/hello | grep -q GNU_RELRO
+
+ # Ensure that we're *not* built with RELRO when setting it to off. We do
+ # not want to check for BIND_NOW however, as the linker might have that
+ # enabled by default.
+ $(RUSTC) -Zrelro-level=off hello.rs
+ ! readelf -l $(TMPDIR)/hello | grep -q GNU_RELRO