summaryrefslogtreecommitdiffstats
path: root/tests/run-make/rustdoc-scrape-examples-invalid-expr
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
commita4b7ed7a42c716ab9f05e351f003d589124fd55d (patch)
treeb620cd3f223850b28716e474e80c58059dca5dd4 /tests/run-make/rustdoc-scrape-examples-invalid-expr
parentAdding upstream version 1.67.1+dfsg1. (diff)
downloadrustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.tar.xz
rustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.zip
Adding upstream version 1.68.2+dfsg1.upstream/1.68.2+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/rustdoc-scrape-examples-invalid-expr')
-rw-r--r--tests/run-make/rustdoc-scrape-examples-invalid-expr/Makefile5
-rw-r--r--tests/run-make/rustdoc-scrape-examples-invalid-expr/examples/ex.rs2
-rw-r--r--tests/run-make/rustdoc-scrape-examples-invalid-expr/src/lib.rs1
3 files changed, 8 insertions, 0 deletions
diff --git a/tests/run-make/rustdoc-scrape-examples-invalid-expr/Makefile b/tests/run-make/rustdoc-scrape-examples-invalid-expr/Makefile
new file mode 100644
index 000000000..7786ff762
--- /dev/null
+++ b/tests/run-make/rustdoc-scrape-examples-invalid-expr/Makefile
@@ -0,0 +1,5 @@
+deps := ex
+
+include ../rustdoc-scrape-examples-multiple/scrape.mk
+
+all: scrape
diff --git a/tests/run-make/rustdoc-scrape-examples-invalid-expr/examples/ex.rs b/tests/run-make/rustdoc-scrape-examples-invalid-expr/examples/ex.rs
new file mode 100644
index 000000000..b342b5b0a
--- /dev/null
+++ b/tests/run-make/rustdoc-scrape-examples-invalid-expr/examples/ex.rs
@@ -0,0 +1,2 @@
+pub struct Foo([usize; foobar::f()]);
+fn main() {}
diff --git a/tests/run-make/rustdoc-scrape-examples-invalid-expr/src/lib.rs b/tests/run-make/rustdoc-scrape-examples-invalid-expr/src/lib.rs
new file mode 100644
index 000000000..c30c99dec
--- /dev/null
+++ b/tests/run-make/rustdoc-scrape-examples-invalid-expr/src/lib.rs
@@ -0,0 +1 @@
+pub const fn f() -> usize { 5 }