summaryrefslogtreecommitdiffstats
path: root/tests/run-make/rustdoc-scrape-examples-remap
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
commita4b7ed7a42c716ab9f05e351f003d589124fd55d (patch)
treeb620cd3f223850b28716e474e80c58059dca5dd4 /tests/run-make/rustdoc-scrape-examples-remap
parentAdding upstream version 1.67.1+dfsg1. (diff)
downloadrustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.tar.xz
rustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.zip
Adding upstream version 1.68.2+dfsg1.upstream/1.68.2+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/rustdoc-scrape-examples-remap')
-rw-r--r--tests/run-make/rustdoc-scrape-examples-remap/Makefile5
-rw-r--r--tests/run-make/rustdoc-scrape-examples-remap/examples/ex.rs4
-rw-r--r--tests/run-make/rustdoc-scrape-examples-remap/src/a.rs1
-rw-r--r--tests/run-make/rustdoc-scrape-examples-remap/src/lib.rs8
4 files changed, 18 insertions, 0 deletions
diff --git a/tests/run-make/rustdoc-scrape-examples-remap/Makefile b/tests/run-make/rustdoc-scrape-examples-remap/Makefile
new file mode 100644
index 000000000..7786ff762
--- /dev/null
+++ b/tests/run-make/rustdoc-scrape-examples-remap/Makefile
@@ -0,0 +1,5 @@
+deps := ex
+
+include ../rustdoc-scrape-examples-multiple/scrape.mk
+
+all: scrape
diff --git a/tests/run-make/rustdoc-scrape-examples-remap/examples/ex.rs b/tests/run-make/rustdoc-scrape-examples-remap/examples/ex.rs
new file mode 100644
index 000000000..1438fdba7
--- /dev/null
+++ b/tests/run-make/rustdoc-scrape-examples-remap/examples/ex.rs
@@ -0,0 +1,4 @@
+fn main() {
+ foobar::b::foo();
+ foobar::c::foo();
+}
diff --git a/tests/run-make/rustdoc-scrape-examples-remap/src/a.rs b/tests/run-make/rustdoc-scrape-examples-remap/src/a.rs
new file mode 100644
index 000000000..b76b4321d
--- /dev/null
+++ b/tests/run-make/rustdoc-scrape-examples-remap/src/a.rs
@@ -0,0 +1 @@
+pub fn foo() {}
diff --git a/tests/run-make/rustdoc-scrape-examples-remap/src/lib.rs b/tests/run-make/rustdoc-scrape-examples-remap/src/lib.rs
new file mode 100644
index 000000000..f525a4270
--- /dev/null
+++ b/tests/run-make/rustdoc-scrape-examples-remap/src/lib.rs
@@ -0,0 +1,8 @@
+// @has foobar/b/fn.foo.html '//*[@class="scraped-example expanded"]' 'ex.rs'
+// @has foobar/c/fn.foo.html '//*[@class="scraped-example expanded"]' 'ex.rs'
+
+#[path = "a.rs"]
+pub mod b;
+
+#[path = "a.rs"]
+pub mod c;