summaryrefslogtreecommitdiffstats
path: root/tests/run-make/rustdoc-verify-output-files/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /tests/run-make/rustdoc-verify-output-files/Makefile
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/rustdoc-verify-output-files/Makefile')
-rw-r--r--tests/run-make/rustdoc-verify-output-files/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/tests/run-make/rustdoc-verify-output-files/Makefile b/tests/run-make/rustdoc-verify-output-files/Makefile
new file mode 100644
index 000000000..bfabbbc65
--- /dev/null
+++ b/tests/run-make/rustdoc-verify-output-files/Makefile
@@ -0,0 +1,36 @@
+include ../../run-make-fulldeps/tools.mk
+
+OUTPUT_DIR := "$(TMPDIR)/rustdoc"
+TMP_OUTPUT_DIR := "$(TMPDIR)/tmp-rustdoc"
+
+all:
+ # Generate html docs
+ $(RUSTDOC) src/lib.rs --crate-name foobar --crate-type lib --out-dir $(OUTPUT_DIR)
+
+ # Copy first output for to check if it's exactly same after second compilation
+ cp -R $(OUTPUT_DIR) $(TMP_OUTPUT_DIR)
+
+ # Generate html docs once again on same output
+ $(RUSTDOC) src/lib.rs --crate-name foobar --crate-type lib --out-dir $(OUTPUT_DIR)
+
+ # Check if everything exactly same
+ $(DIFF) -r -q $(OUTPUT_DIR) $(TMP_OUTPUT_DIR)
+
+ # Generate json doc on the same output
+ $(RUSTDOC) src/lib.rs --crate-name foobar --crate-type lib --out-dir $(OUTPUT_DIR) -Z unstable-options --output-format json
+
+ # Check if expected json file is generated
+ [ -e $(OUTPUT_DIR)/foobar.json ]
+
+ # TODO
+ # We should re-generate json doc once again and compare the diff with previously
+ # generated one. Because layout of json docs changes in each compilation, we can't
+ # do that currently.
+ #
+ # See https://github.com/rust-lang/rust/issues/103785#issuecomment-1307425590 for details.
+
+ # remove generated json doc
+ rm $(OUTPUT_DIR)/foobar.json
+
+ # Check if json doc compilation broke any of the html files generated previously
+ $(DIFF) -r -q $(OUTPUT_DIR) $(TMP_OUTPUT_DIR)