summaryrefslogtreecommitdiffstats
path: root/tests/run-make/sanitizer-staticlib-link
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/sanitizer-staticlib-link
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/sanitizer-staticlib-link')
-rw-r--r--tests/run-make/sanitizer-staticlib-link/Makefile20
-rw-r--r--tests/run-make/sanitizer-staticlib-link/library.rs5
-rw-r--r--tests/run-make/sanitizer-staticlib-link/program.c6
-rw-r--r--tests/run-make/sanitizer-staticlib-link/program.rs10
4 files changed, 41 insertions, 0 deletions
diff --git a/tests/run-make/sanitizer-staticlib-link/Makefile b/tests/run-make/sanitizer-staticlib-link/Makefile
new file mode 100644
index 000000000..7b1a286ed
--- /dev/null
+++ b/tests/run-make/sanitizer-staticlib-link/Makefile
@@ -0,0 +1,20 @@
+# needs-sanitizer-support
+# needs-sanitizer-address
+
+include ../tools.mk
+
+# This test first builds a staticlib with AddressSanitizer and checks that
+# linking it to an executable fails due to the missing sanitizer runtime.
+# It then builds an executable linking to the staticlib and checks that
+# the fault in the staticlib is detected correctly.
+
+# Note that checking for the link failure actually checks two things at once:
+# 1) That the library has the sanitizer intrumentation
+# 2) and that library does not have the sanitizer runtime
+
+all:
+ $(RUSTC) -g -Z sanitizer=address --crate-type staticlib --target $(TARGET) library.rs
+ ! $(CC) program.c $(call STATICLIB,library) $(call OUT_EXE,program) $(EXTRACFLAGS) $(EXTRACXXFLAGS)
+ $(RUSTC) -g -Z sanitizer=address --crate-type bin --target $(TARGET) -L . program.rs
+ LD_LIBRARY_PATH=$(TMPDIR) $(TMPDIR)/program 2>&1 | $(CGREP) stack-buffer-overflow
+
diff --git a/tests/run-make/sanitizer-staticlib-link/library.rs b/tests/run-make/sanitizer-staticlib-link/library.rs
new file mode 100644
index 000000000..f2a52cb5c
--- /dev/null
+++ b/tests/run-make/sanitizer-staticlib-link/library.rs
@@ -0,0 +1,5 @@
+#[no_mangle]
+pub extern "C" fn overflow() {
+ let xs = [0, 1, 2, 3];
+ let _y = unsafe { *xs.as_ptr().offset(4) };
+}
diff --git a/tests/run-make/sanitizer-staticlib-link/program.c b/tests/run-make/sanitizer-staticlib-link/program.c
new file mode 100644
index 000000000..735e2b147
--- /dev/null
+++ b/tests/run-make/sanitizer-staticlib-link/program.c
@@ -0,0 +1,6 @@
+void overflow();
+
+int main() {
+ overflow();
+ return 0;
+}
diff --git a/tests/run-make/sanitizer-staticlib-link/program.rs b/tests/run-make/sanitizer-staticlib-link/program.rs
new file mode 100644
index 000000000..ec59bdb11
--- /dev/null
+++ b/tests/run-make/sanitizer-staticlib-link/program.rs
@@ -0,0 +1,10 @@
+#[link(name = "library")]
+extern "C" {
+ fn overflow();
+}
+
+fn main() {
+ unsafe {
+ overflow();
+ }
+}