summaryrefslogtreecommitdiffstats
path: root/tests/run-make/symlinked-extern/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/symlinked-extern/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/symlinked-extern/Makefile')
-rw-r--r--tests/run-make/symlinked-extern/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/symlinked-extern/Makefile b/tests/run-make/symlinked-extern/Makefile
new file mode 100644
index 000000000..28c764b84
--- /dev/null
+++ b/tests/run-make/symlinked-extern/Makefile
@@ -0,0 +1,12 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# ignore-windows
+# `ln` is actually `cp` on msys.
+
+all:
+ $(RUSTC) foo.rs
+ mkdir -p $(TMPDIR)/other
+ ln -nsf $(TMPDIR)/libfoo.rlib $(TMPDIR)/other
+ $(RUSTC) bar.rs -L $(TMPDIR)
+ $(RUSTC) baz.rs --extern foo=$(TMPDIR)/other/libfoo.rlib -L $(TMPDIR)