summaryrefslogtreecommitdiffstats
path: root/tests/run-make/weird-output-filenames/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/weird-output-filenames/Makefile
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/weird-output-filenames/Makefile')
-rw-r--r--tests/run-make/weird-output-filenames/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/tests/run-make/weird-output-filenames/Makefile b/tests/run-make/weird-output-filenames/Makefile
new file mode 100644
index 000000000..d3a34e3b4
--- /dev/null
+++ b/tests/run-make/weird-output-filenames/Makefile
@@ -0,0 +1,15 @@
+include ../tools.mk
+
+all:
+ cp foo.rs $(TMPDIR)/.foo.rs
+ $(RUSTC) $(TMPDIR)/.foo.rs 2>&1 \
+ | $(CGREP) -e "invalid character.*in crate name:"
+ cp foo.rs $(TMPDIR)/.foo.bar
+ $(RUSTC) $(TMPDIR)/.foo.bar 2>&1 \
+ | $(CGREP) -e "invalid character.*in crate name:"
+ cp foo.rs $(TMPDIR)/+foo+bar.rs
+ $(RUSTC) $(TMPDIR)/+foo+bar.rs 2>&1 \
+ | $(CGREP) -e "invalid character.*in crate name:"
+ cp foo.rs $(TMPDIR)/-foo.rs
+ $(RUSTC) $(TMPDIR)/-foo.rs 2>&1 \
+ | $(CGREP) 'crate names cannot start with a `-`'