summaryrefslogtreecommitdiffstats
path: root/tests/run-make/windows-subsystem
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /tests/run-make/windows-subsystem
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/windows-subsystem')
-rw-r--r--tests/run-make/windows-subsystem/Makefile6
-rw-r--r--tests/run-make/windows-subsystem/console.rs3
-rw-r--r--tests/run-make/windows-subsystem/windows.rs3
3 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/windows-subsystem/Makefile b/tests/run-make/windows-subsystem/Makefile
new file mode 100644
index 000000000..e3cf9181d
--- /dev/null
+++ b/tests/run-make/windows-subsystem/Makefile
@@ -0,0 +1,6 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) windows.rs
+ $(RUSTC) console.rs
diff --git a/tests/run-make/windows-subsystem/console.rs b/tests/run-make/windows-subsystem/console.rs
new file mode 100644
index 000000000..61a92eb6a
--- /dev/null
+++ b/tests/run-make/windows-subsystem/console.rs
@@ -0,0 +1,3 @@
+#![windows_subsystem = "console"]
+
+fn main() {}
diff --git a/tests/run-make/windows-subsystem/windows.rs b/tests/run-make/windows-subsystem/windows.rs
new file mode 100644
index 000000000..1138248f0
--- /dev/null
+++ b/tests/run-make/windows-subsystem/windows.rs
@@ -0,0 +1,3 @@
+#![windows_subsystem = "windows"]
+
+fn main() {}