summaryrefslogtreecommitdiffstats
path: root/vendor/anstream/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /vendor/anstream/Cargo.toml
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/anstream/Cargo.toml')
-rw-r--r--vendor/anstream/Cargo.toml144
1 files changed, 144 insertions, 0 deletions
diff --git a/vendor/anstream/Cargo.toml b/vendor/anstream/Cargo.toml
new file mode 100644
index 000000000..eb049069c
--- /dev/null
+++ b/vendor/anstream/Cargo.toml
@@ -0,0 +1,144 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.64.0"
+name = "anstream"
+version = "0.2.6"
+include = [
+ "build.rs",
+ "src/**/*",
+ "Cargo.toml",
+ "LICENSE*",
+ "README.md",
+ "benches/**/*",
+ "examples/**/*",
+]
+description = "A simple cross platform library for writing colored text to a terminal."
+homepage = "https://github.com/rust-cli/anstyle"
+readme = "README.md"
+keywords = [
+ "ansi",
+ "terminal",
+ "color",
+ "strip",
+ "wincon",
+]
+categories = ["command-line-interface"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-cli/anstyle.git"
+
+[package.metadata.docs.rs]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+cargo-args = [
+ "-Zunstable-options",
+ "-Zrustdoc-scrape-examples",
+]
+
+[[package.metadata.release.pre-release-replacements]]
+file = "CHANGELOG.md"
+search = "Unreleased"
+replace = "{{version}}"
+min = 1
+
+[[package.metadata.release.pre-release-replacements]]
+file = "CHANGELOG.md"
+search = '\.\.\.HEAD'
+replace = "...{{tag_name}}"
+exactly = 1
+
+[[package.metadata.release.pre-release-replacements]]
+file = "CHANGELOG.md"
+search = "ReleaseDate"
+replace = "{{date}}"
+min = 1
+
+[[package.metadata.release.pre-release-replacements]]
+file = "CHANGELOG.md"
+search = "<!-- next-header -->"
+replace = """
+<!-- next-header -->
+## [Unreleased] - ReleaseDate
+"""
+exactly = 1
+
+[[package.metadata.release.pre-release-replacements]]
+file = "CHANGELOG.md"
+search = "<!-- next-url -->"
+replace = """
+<!-- next-url -->
+[Unreleased]: https://github.com/rust-cli/anstyle/compare/{{tag_name}}...HEAD"""
+exactly = 1
+
+[[bench]]
+name = "strip"
+harness = false
+
+[[bench]]
+name = "wincon"
+harness = false
+
+[[bench]]
+name = "stream"
+harness = false
+
+[dependencies.anstyle]
+version = "0.3.0"
+
+[dependencies.anstyle-parse]
+version = "0.1.0"
+
+[dependencies.concolor-override]
+version = "1.0.0"
+optional = true
+
+[dependencies.concolor-query]
+version = "0.3.1"
+optional = true
+
+[dependencies.is-terminal]
+version = "0.4.4"
+optional = true
+
+[dependencies.utf8parse]
+version = "0.2.1"
+
+[dev-dependencies.criterion]
+version = "0.4.0"
+
+[dev-dependencies.owo-colors]
+version = "3.5.0"
+
+[dev-dependencies.proptest]
+version = "1.1.0"
+
+[dev-dependencies.strip-ansi-escapes]
+version = "0.1.1"
+
+[features]
+auto = [
+ "dep:concolor-query",
+ "dep:concolor-override",
+ "dep:is-terminal",
+]
+default = [
+ "auto",
+ "wincon",
+]
+wincon = ["dep:anstyle-wincon"]
+
+[target."cfg(windows)".dependencies.anstyle-wincon]
+version = "0.2.0"
+optional = true