summaryrefslogtreecommitdiffstats
path: root/vendor/bitflags/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
commit837b550238aa671a591ccf282dddeab29cadb206 (patch)
tree914b6b8862bace72bd3245ca184d374b08d8a672 /vendor/bitflags/Cargo.toml
parentAdding debian version 1.70.0+dfsg2-1. (diff)
downloadrustc-837b550238aa671a591ccf282dddeab29cadb206.tar.xz
rustc-837b550238aa671a591ccf282dddeab29cadb206.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/bitflags/Cargo.toml')
-rw-r--r--vendor/bitflags/Cargo.toml70
1 files changed, 52 insertions, 18 deletions
diff --git a/vendor/bitflags/Cargo.toml b/vendor/bitflags/Cargo.toml
index 9d54c725a..06afeef5b 100644
--- a/vendor/bitflags/Cargo.toml
+++ b/vendor/bitflags/Cargo.toml
@@ -3,29 +3,49 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
-edition = "2018"
+edition = "2021"
+rust-version = "1.56.0"
name = "bitflags"
-version = "1.3.2"
+version = "2.2.1"
authors = ["The Rust Project Developers"]
-exclude = ["bors.toml"]
-description = "A macro to generate structures which behave like bitflags.\n"
+exclude = [
+ "tests",
+ ".github",
+]
+description = """
+A macro to generate structures which behave like bitflags.
+"""
homepage = "https://github.com/bitflags/bitflags"
documentation = "https://docs.rs/bitflags"
readme = "README.md"
-keywords = ["bit", "bitmask", "bitflags", "flags"]
+keywords = [
+ "bit",
+ "bitmask",
+ "bitflags",
+ "flags",
+]
categories = ["no-std"]
-license = "MIT/Apache-2.0"
+license = "MIT OR Apache-2.0"
repository = "https://github.com/bitflags/bitflags"
+
[package.metadata.docs.rs]
features = ["example_generated"]
+
+[dependencies.arbitrary]
+version = "1.0"
+optional = true
+
+[dependencies.bytemuck]
+version = "1.0"
+optional = true
+
[dependencies.compiler_builtins]
version = "0.1.2"
optional = true
@@ -34,10 +54,21 @@ optional = true
version = "1.0.0"
optional = true
package = "rustc-std-workspace-core"
-[dev-dependencies.rustversion]
+
+[dependencies.serde]
version = "1.0"
+optional = true
+default-features = false
+
+[dev-dependencies.arbitrary]
+version = "1.0"
+features = ["derive"]
-[dev-dependencies.serde]
+[dev-dependencies.bytemuck]
+version = "1.0"
+features = ["derive"]
+
+[dev-dependencies.rustversion]
version = "1.0"
[dev-dependencies.serde_derive]
@@ -46,13 +77,16 @@ version = "1.0"
[dev-dependencies.serde_json]
version = "1.0"
-[dev-dependencies.trybuild]
+[dev-dependencies.serde_test]
version = "1.0"
-[dev-dependencies.walkdir]
-version = "2.3"
+[dev-dependencies.trybuild]
+version = "1.0"
[features]
-default = []
example_generated = []
-rustc-dep-of-std = ["core", "compiler_builtins"]
+rustc-dep-of-std = [
+ "core",
+ "compiler_builtins",
+]
+std = []