summaryrefslogtreecommitdiffstats
path: root/vendor/cargo_metadata/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/cargo_metadata/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/cargo_metadata/Cargo.toml')
-rw-r--r--vendor/cargo_metadata/Cargo.toml52
1 files changed, 52 insertions, 0 deletions
diff --git a/vendor/cargo_metadata/Cargo.toml b/vendor/cargo_metadata/Cargo.toml
new file mode 100644
index 000000000..90f1b1ce0
--- /dev/null
+++ b/vendor/cargo_metadata/Cargo.toml
@@ -0,0 +1,52 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.42.0"
+name = "cargo_metadata"
+version = "0.15.0"
+authors = ["Oliver Schneider <git-spam-no-reply9815368754983@oli-obk.de>"]
+description = "structured access to the output of `cargo metadata`"
+readme = "README.md"
+license = "MIT"
+repository = "https://github.com/oli-obk/cargo_metadata"
+
+[package.metadata.cargo_metadata_test]
+some_field = true
+other_field = "foo"
+
+[dependencies.camino]
+version = "1.0.7"
+features = ["serde1"]
+
+[dependencies.cargo-platform]
+version = "0.1.2"
+
+[dependencies.derive_builder]
+version = "0.11.1"
+optional = true
+
+[dependencies.semver]
+version = "1.0.7"
+features = ["serde"]
+
+[dependencies.serde]
+version = "1.0.136"
+features = ["derive"]
+
+[dependencies.serde_json]
+version = "1.0.79"
+features = ["unbounded_depth"]
+
+[features]
+builder = ["derive_builder"]
+default = []