summaryrefslogtreecommitdiffstats
path: root/vendor/chalk-derive-0.87.0/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /vendor/chalk-derive-0.87.0/Cargo.toml
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/chalk-derive-0.87.0/Cargo.toml')
-rw-r--r--vendor/chalk-derive-0.87.0/Cargo.toml44
1 files changed, 44 insertions, 0 deletions
diff --git a/vendor/chalk-derive-0.87.0/Cargo.toml b/vendor/chalk-derive-0.87.0/Cargo.toml
new file mode 100644
index 000000000..45bade326
--- /dev/null
+++ b/vendor/chalk-derive-0.87.0/Cargo.toml
@@ -0,0 +1,44 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "chalk-derive"
+version = "0.87.0"
+authors = [
+ "Rust Compiler Team",
+ "Chalk developers",
+]
+description = "A helper crate for use by chalk crates for `derive` macros."
+readme = "README.md"
+keywords = [
+ "compiler",
+ "traits",
+ "prolog",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/chalk"
+
+[lib]
+proc-macro = true
+
+[dependencies.proc-macro2]
+version = "1.0"
+
+[dependencies.quote]
+version = "1.0"
+
+[dependencies.syn]
+version = "1.0"
+features = ["full"]
+
+[dependencies.synstructure]
+version = "0.12.5"