summaryrefslogtreecommitdiffstats
path: root/vendor/chalk-ir-0.87.0/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:58 +0000
commita4b7ed7a42c716ab9f05e351f003d589124fd55d (patch)
treeb620cd3f223850b28716e474e80c58059dca5dd4 /vendor/chalk-ir-0.87.0/Cargo.toml
parentAdding upstream version 1.67.1+dfsg1. (diff)
downloadrustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.tar.xz
rustc-a4b7ed7a42c716ab9f05e351f003d589124fd55d.zip
Adding upstream version 1.68.2+dfsg1.upstream/1.68.2+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/chalk-ir-0.87.0/Cargo.toml')
-rw-r--r--vendor/chalk-ir-0.87.0/Cargo.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/vendor/chalk-ir-0.87.0/Cargo.toml b/vendor/chalk-ir-0.87.0/Cargo.toml
new file mode 100644
index 000000000..16e1e83b2
--- /dev/null
+++ b/vendor/chalk-ir-0.87.0/Cargo.toml
@@ -0,0 +1,37 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "chalk-ir"
+version = "0.87.0"
+authors = [
+ "Rust Compiler Team",
+ "Chalk developers",
+]
+description = "Chalk's internal representation of types, goals, and clauses"
+readme = "README.md"
+keywords = [
+ "compiler",
+ "traits",
+ "prolog",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/chalk"
+
+[dependencies.bitflags]
+version = "1.2.1"
+
+[dependencies.chalk-derive]
+version = "=0.87.0"
+
+[dependencies.lazy_static]
+version = "1.4.0"