summaryrefslogtreecommitdiffstats
path: root/vendor/clap-3.2.20/examples/cargo-example.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:11:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:12:43 +0000
commitcf94bdc0742c13e2a0cac864c478b8626b266e1b (patch)
tree044670aa50cc5e2b4229aa0b6b3df6676730c0a6 /vendor/clap-3.2.20/examples/cargo-example.md
parentAdding debian version 1.65.0+dfsg1-2. (diff)
downloadrustc-cf94bdc0742c13e2a0cac864c478b8626b266e1b.tar.xz
rustc-cf94bdc0742c13e2a0cac864c478b8626b266e1b.zip
Merging upstream version 1.66.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/clap-3.2.20/examples/cargo-example.md')
-rw-r--r--vendor/clap-3.2.20/examples/cargo-example.md43
1 files changed, 43 insertions, 0 deletions
diff --git a/vendor/clap-3.2.20/examples/cargo-example.md b/vendor/clap-3.2.20/examples/cargo-example.md
new file mode 100644
index 000000000..6fb6a3c4d
--- /dev/null
+++ b/vendor/clap-3.2.20/examples/cargo-example.md
@@ -0,0 +1,43 @@
+For more on creating a custom subcommand, see [the cargo
+book](https://doc.rust-lang.org/cargo/reference/external-tools.html#custom-subcommands).
+The crate [`clap-cargo`](https://github.com/crate-ci/clap-cargo) can help in
+mimicking cargo's interface.
+
+The help looks like:
+```console
+$ cargo-example --help
+cargo
+
+USAGE:
+ cargo <SUBCOMMAND>
+
+OPTIONS:
+ -h, --help Print help information
+
+SUBCOMMANDS:
+ example A simple to use, efficient, and full-featured Command Line Argument Parser
+ help Print this message or the help of the given subcommand(s)
+
+$ cargo-example example --help
+cargo-example [..]
+A simple to use, efficient, and full-featured Command Line Argument Parser
+
+USAGE:
+ cargo example [OPTIONS]
+
+OPTIONS:
+ -h, --help Print help information
+ --manifest-path <PATH>
+ -V, --version Print version information
+
+```
+
+Then to directly invoke the command, run:
+```console
+$ cargo-example example
+None
+
+$ cargo-example example --manifest-path Cargo.toml
+Some("Cargo.toml")
+
+```