summaryrefslogtreecommitdiffstats
path: root/vendor/clap_builder/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /vendor/clap_builder/Cargo.toml
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/clap_builder/Cargo.toml')
-rw-r--r--vendor/clap_builder/Cargo.toml174
1 files changed, 174 insertions, 0 deletions
diff --git a/vendor/clap_builder/Cargo.toml b/vendor/clap_builder/Cargo.toml
new file mode 100644
index 000000000..1441cfe0e
--- /dev/null
+++ b/vendor/clap_builder/Cargo.toml
@@ -0,0 +1,174 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.64.0"
+name = "clap_builder"
+version = "4.2.1"
+include = [
+ "build.rs",
+ "src/**/*",
+ "Cargo.toml",
+ "LICENSE*",
+ "README.md",
+ "benches/**/*",
+ "examples/**/*",
+]
+description = "A simple to use, efficient, and full-featured Command Line Argument Parser"
+readme = "README.md"
+keywords = [
+ "argument",
+ "cli",
+ "arg",
+ "parser",
+ "parse",
+]
+categories = ["command-line-interface"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/clap-rs/clap"
+
+[package.metadata.docs.rs]
+features = ["unstable-doc"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+cargo-args = [
+ "-Zunstable-options",
+ "-Zrustdoc-scrape-examples",
+]
+
+[package.metadata.playground]
+features = ["unstable-doc"]
+
+[package.metadata.release]
+shared-version = true
+dependent-version = "upgrade"
+tag-name = "v{{version}}"
+
+[lib]
+bench = false
+
+[dependencies.anstream]
+version = "0.2.5"
+optional = true
+
+[dependencies.anstyle]
+version = "0.3.5"
+features = ["std"]
+optional = true
+
+[dependencies.backtrace]
+version = "0.3.67"
+optional = true
+
+[dependencies.bitflags]
+version = "1.2.0"
+
+[dependencies.clap_lex]
+version = "0.4.0"
+
+[dependencies.once_cell]
+version = "1.12.0"
+optional = true
+
+[dependencies.strsim]
+version = "0.10.0"
+optional = true
+
+[dependencies.terminal_size]
+version = "0.2.1"
+optional = true
+
+[dependencies.unicase]
+version = "2.6.0"
+optional = true
+
+[dependencies.unicode-width]
+version = "0.1.9"
+optional = true
+
+[dev-dependencies.color-print]
+version = "0.3.4"
+
+[dev-dependencies.humantime]
+version = "2.1.0"
+
+[dev-dependencies.rustversion]
+version = "1.0.12"
+
+[dev-dependencies.shlex]
+version = "1.1.0"
+
+[dev-dependencies.snapbox]
+version = "0.4.10"
+
+[dev-dependencies.static_assertions]
+version = "1.1.0"
+
+[dev-dependencies.trybuild]
+version = "1.0.77"
+
+[dev-dependencies.trycmd]
+version = "0.14.15"
+features = [
+ "color-auto",
+ "diff",
+ "examples",
+]
+default-features = false
+
+[dev-dependencies.unic-emoji-char]
+version = "0.9.0"
+
+[features]
+cargo = ["dep:once_cell"]
+color = [
+ "dep:anstyle",
+ "dep:anstream",
+]
+debug = ["dep:backtrace"]
+default = [
+ "std",
+ "color",
+ "help",
+ "usage",
+ "error-context",
+ "suggestions",
+]
+deprecated = []
+env = []
+error-context = []
+help = []
+std = []
+string = []
+suggestions = [
+ "dep:strsim",
+ "error-context",
+]
+unicode = [
+ "dep:unicode-width",
+ "dep:unicase",
+]
+unstable-doc = [
+ "cargo",
+ "wrap_help",
+ "env",
+ "unicode",
+ "string",
+]
+unstable-v5 = ["deprecated"]
+usage = []
+wrap_help = [
+ "help",
+ "dep:terminal_size",
+]