summaryrefslogtreecommitdiffstats
path: root/vendor/compiletest_rs/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/compiletest_rs/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/compiletest_rs/Cargo.toml')
-rw-r--r--vendor/compiletest_rs/Cargo.toml83
1 files changed, 83 insertions, 0 deletions
diff --git a/vendor/compiletest_rs/Cargo.toml b/vendor/compiletest_rs/Cargo.toml
new file mode 100644
index 000000000..9403548b8
--- /dev/null
+++ b/vendor/compiletest_rs/Cargo.toml
@@ -0,0 +1,83 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "compiletest_rs"
+version = "0.8.0"
+authors = [
+ "The Rust Project Developers",
+ "Thomas Bracht Laumann Jespersen <laumann.thomas@gmail.com>",
+ "Manish Goregaokar <manishsmail@gmail.com>",
+]
+description = "The compiletest utility from the Rust compiler as a standalone testing harness"
+readme = "README.md"
+keywords = [
+ "compiletest",
+ "test",
+ "plugin",
+]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/laumann/compiletest-rs"
+
+[lib]
+name = "compiletest_rs"
+
+[dependencies.diff]
+version = "0.1.10"
+
+[dependencies.filetime]
+version = "0.2"
+
+[dependencies.getopts]
+version = "0.2"
+
+[dependencies.lazy_static]
+version = "1.4"
+
+[dependencies.log]
+version = "0.4"
+
+[dependencies.regex]
+version = "1.0"
+
+[dependencies.rustfix]
+version = "0.6"
+
+[dependencies.serde]
+version = "1.0"
+
+[dependencies.serde_derive]
+version = "1.0"
+
+[dependencies.serde_json]
+version = "1.0"
+
+[dependencies.tempfile]
+version = "3.0"
+optional = true
+
+[dependencies.tester]
+version = "0.9"
+
+[features]
+rustc = []
+stable = []
+tmp = ["tempfile"]
+
+[target."cfg(unix)".dependencies.libc]
+version = "0.2"
+
+[target."cfg(windows)".dependencies.miow]
+version = "0.3"
+
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = ["winerror"]