summaryrefslogtreecommitdiffstats
path: root/vendor/cov-mark/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/cov-mark/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/cov-mark/Cargo.toml')
-rw-r--r--vendor/cov-mark/Cargo.toml31
1 files changed, 31 insertions, 0 deletions
diff --git a/vendor/cov-mark/Cargo.toml b/vendor/cov-mark/Cargo.toml
new file mode 100644
index 000000000..d3e7812ca
--- /dev/null
+++ b/vendor/cov-mark/Cargo.toml
@@ -0,0 +1,31 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "cov-mark"
+version = "2.0.0-pre.1"
+authors = ["Aleksey Kladov <aleksey.kladov@gmail.com>", "Simonas Kazlauskas <cov-mark@kazlauskas.me>"]
+exclude = [".github/", "bors.toml", "rustfmt.toml"]
+description = "Manual coverage marks."
+documentation = "https://docs.rs/cov-mark"
+keywords = ["coverage", "test"]
+categories = ["development-tools"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/matklad/cov-mark"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "nightly_docs"]
+
+[features]
+default = ["enable"]
+enable = []