summaryrefslogtreecommitdiffstats
path: root/vendor/cov-mark
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/cov-mark
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/cov-mark')
-rw-r--r--vendor/cov-mark/.cargo-checksum.json1
-rw-r--r--vendor/cov-mark/Cargo.toml31
-rw-r--r--vendor/cov-mark/LICENSE-APACHE201
-rw-r--r--vendor/cov-mark/LICENSE-MIT23
-rw-r--r--vendor/cov-mark/README.md21
-rw-r--r--vendor/cov-mark/src/lib.rs272
-rw-r--r--vendor/cov-mark/tests/smoke.rs27
7 files changed, 576 insertions, 0 deletions
diff --git a/vendor/cov-mark/.cargo-checksum.json b/vendor/cov-mark/.cargo-checksum.json
new file mode 100644
index 000000000..594f68f25
--- /dev/null
+++ b/vendor/cov-mark/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"1d8ced7dc9a974e1c66fade34419cf217bdf9a6139d646faaf3b8f51b736958c","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"23f18e03dc49df91622fe2a76176497404e46ced8a715d9d2b67a7446571cca3","README.md":"6df4d461276c99625d9cb418f956e4b1ecec895a82876faf10dc24b804a5d8fd","src/lib.rs":"686d9d91a2a77ad0a19ede20e898dc46300b462d9db0ef9e26f7981f1334e5ac","tests/smoke.rs":"602921279759a874a50ec46bd13cea11738f98202380ebd6555d531e517537e0"},"package":"0d48d8f76bd9331f19fe2aaf3821a9f9fb32c3963e1e3d6ce82a8c09cef7444a"} \ No newline at end of file
diff --git a/vendor/cov-mark/Cargo.toml b/vendor/cov-mark/Cargo.toml
new file mode 100644
index 000000000..d3e7812ca
--- /dev/null
+++ b/vendor/cov-mark/Cargo.toml
@@ -0,0 +1,31 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "cov-mark"
+version = "2.0.0-pre.1"
+authors = ["Aleksey Kladov <aleksey.kladov@gmail.com>", "Simonas Kazlauskas <cov-mark@kazlauskas.me>"]
+exclude = [".github/", "bors.toml", "rustfmt.toml"]
+description = "Manual coverage marks."
+documentation = "https://docs.rs/cov-mark"
+keywords = ["coverage", "test"]
+categories = ["development-tools"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/matklad/cov-mark"
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = ["--cfg", "nightly_docs"]
+
+[features]
+default = ["enable"]
+enable = []
diff --git a/vendor/cov-mark/LICENSE-APACHE b/vendor/cov-mark/LICENSE-APACHE
new file mode 100644
index 000000000..16fe87b06
--- /dev/null
+++ b/vendor/cov-mark/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/vendor/cov-mark/LICENSE-MIT b/vendor/cov-mark/LICENSE-MIT
new file mode 100644
index 000000000..31aa79387
--- /dev/null
+++ b/vendor/cov-mark/LICENSE-MIT
@@ -0,0 +1,23 @@
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/vendor/cov-mark/README.md b/vendor/cov-mark/README.md
new file mode 100644
index 000000000..81c1fcec0
--- /dev/null
+++ b/vendor/cov-mark/README.md
@@ -0,0 +1,21 @@
+# cov-mark
+
+Verify that your tests exercise the conditions you think they are exercising
+
+```rust
+fn safe_divide(dividend: u32, divisor: u32) -> u32 {
+ if divisor == 0 {
+ cov_mark::hit!(save_divide_zero);
+ return 0;
+ }
+ dividend / divisor
+}
+
+#[test]
+fn test_safe_divide_by_zero() {
+ cov_mark::check!(save_divide_zero);
+ assert_eq!(safe_divide(92, 0), 0);
+}
+```
+
+See [the docs](https://docs.rs/cov-mark) for details
diff --git a/vendor/cov-mark/src/lib.rs b/vendor/cov-mark/src/lib.rs
new file mode 100644
index 000000000..a2ee0cad1
--- /dev/null
+++ b/vendor/cov-mark/src/lib.rs
@@ -0,0 +1,272 @@
+//! # cov-mark
+//!
+//! This library at its core provides two macros, [`hit!`] and [`check!`],
+//! which can be used to verify that a certain test exercises a certain code
+//! path.
+//!
+//! Here's a short example:
+//!
+//! ```
+//! fn parse_date(s: &str) -> Option<(u32, u32, u32)> {
+//! if 10 != s.len() {
+//! // By using `cov_mark::hit!`
+//! // we signal which test exercises this code.
+//! cov_mark::hit!(short_date);
+//! return None;
+//! }
+//!
+//! if "-" != &s[4..5] || "-" != &s[7..8] {
+//! cov_mark::hit!(bad_dashes);
+//! return None;
+//! }
+//! // ...
+//! # unimplemented!()
+//! }
+//!
+//! #[test]
+//! fn test_parse_date() {
+//! {
+//! // `cov_mark::check!` creates a guard object
+//! // that verifies that by the end of the scope we've
+//! // executed the corresponding `cov_mark::hit`.
+//! cov_mark::check!(short_date);
+//! assert!(parse_date("92").is_none());
+//! }
+//!
+//! // This will fail. Although the test looks like
+//! // it exercises the second condition, it does not.
+//! // The call to `covers!` call catches this bug in the test.
+//! // {
+//! // cov_mark::check!(bad_dashes);;
+//! // assert!(parse_date("27.2.2013").is_none());
+//! // }
+//!
+//! {
+//! cov_mark::check!(bad_dashes);
+//! assert!(parse_date("27.02.2013").is_none());
+//! }
+//! }
+//!
+//! # fn main() {}
+//! ```
+//!
+//! Here's why coverage marks are useful:
+//!
+//! * Verifying that something doesn't happen for the *right* reason.
+//! * Finding the test that exercises the code (grep for `check!(mark_name)`).
+//! * Finding the code that the test is supposed to check (grep for `hit!(mark_name)`).
+//! * Making sure that code and tests don't diverge during refactorings.
+//! * (If used pervasively) Verifying that each branch has a corresponding test.
+//!
+//! # Limitations
+//!
+//! * In the presence of threads, [`check!`] may falsely pass, if the
+//! mark is hit by an unrelated thread, unless the `thread-local` feature is
+//! enabled.
+//! * Names of marks must be globally unique.
+//! * [`check!`] can't be used in integration tests.
+//!
+//! # Implementation Details
+//!
+//! Each coverage mark is an `AtomicUsize` counter. [`hit!`] increments
+//! this counter, [`check!`] returns a guard object which checks that
+//! the mark was incremented. When the `thread-local` feature is enabled,
+//! each counter is stored as a thread-local, allowing for more accurate
+//! counting.
+//!
+//! Counters are declared using `#[no_mangle]` attribute, so that [`hit!`] and
+//! [`check!`] both can find the mark without the need to declare it in a common
+//! module. Aren't the linkers ~~horrible~~ wonderful?
+//!
+//! # Safety
+//!
+//! Technically, the [`hit!`] macro in this crate is unsound: it uses `extern "C"
+//! #[no_mangle]` symbol, which *could* clash with an existing symbol and cause
+//! UB. For example, `cov_mark::hit!(main)` may segfault. That said:
+//!
+//! * If there's no existing symbol, the result is a linker error.
+//! * If there exists corresponding `cov_mark::check!`, the result is a linker
+//! error.
+//! * Code inside `cov_mark::hit!` is hidden under `#[cfg(test)]`.
+//!
+//! It is believed that it is practically impossible to cause UB by accident
+//! when using this crate. For this reason, the `hit` macro hides unsafety
+//! inside.
+
+#![cfg_attr(nightly_docs, deny(broken_intra_doc_links))]
+#![cfg_attr(nightly_docs, feature(doc_cfg))]
+
+/// Hit a mark with a specified name.
+///
+/// # Example
+///
+/// ```
+/// fn safe_divide(dividend: u32, divisor: u32) -> u32 {
+/// if divisor == 0 {
+/// cov_mark::hit!(save_divide_zero);
+/// return 0;
+/// }
+/// dividend / divisor
+/// }
+/// ```
+#[macro_export]
+macro_rules! hit {
+ ($ident:ident) => {
+ $crate::__rt::hit(stringify!($ident))
+ };
+}
+
+/// Checks that a specified mark was hit.
+///
+/// # Example
+///
+/// ```
+/// #[test]
+/// fn test_safe_divide_by_zero() {
+/// cov_mark::check!(save_divide_zero);
+/// assert_eq!(safe_divide(92, 0), 0);
+/// }
+/// # fn safe_divide(dividend: u32, divisor: u32) -> u32 {
+/// # if divisor == 0 {
+/// # cov_mark::hit!(save_divide_zero);
+/// # return 0;
+/// # }
+/// # dividend / divisor
+/// # }
+/// ```
+#[macro_export]
+macro_rules! check {
+ ($ident:ident) => {
+ let _guard = $crate::__rt::Guard::new(stringify!($ident), None);
+ };
+}
+
+/// Checks that a specified mark was hit exactly the specified number of times.
+///
+/// # Example
+///
+/// ```
+/// struct CoveredDropper;
+/// impl Drop for CoveredDropper {
+/// fn drop(&mut self) {
+/// cov_mark::hit!(covered_dropper_drops);
+/// }
+/// }
+///
+/// #[test]
+/// fn drop_count_test() {
+/// cov_mark::check_count!(covered_dropper_drops, 2);
+/// let _covered_dropper1 = CoveredDropper;
+/// let _covered_dropper2 = CoveredDropper;
+/// }
+/// ```
+#[macro_export]
+macro_rules! check_count {
+ ($ident:ident, $count: literal) => {
+ let _guard = $crate::__rt::Guard::new(stringify!($ident), Some($count));
+ };
+}
+
+#[doc(hidden)]
+#[cfg(feature = "enable")]
+pub mod __rt {
+ use std::{
+ cell::{Cell, RefCell},
+ rc::Rc,
+ sync::atomic::{AtomicUsize, Ordering::Relaxed},
+ };
+
+ /// Even with
+ /// https://github.com/rust-lang/rust/commit/641d3b09f41b441f2c2618de32983ad3d13ea3f8,
+ /// a `thread_local` generates significantly more verbose assembly on x86
+ /// than atomic, so we'll use atomic for the fast path
+ static LEVEL: AtomicUsize = AtomicUsize::new(0);
+
+ thread_local! {
+ static ACTIVE: RefCell<Vec<Rc<GuardInner>>> = Default::default();
+ }
+
+ #[inline(always)]
+ pub fn hit(key: &'static str) {
+ if LEVEL.load(Relaxed) > 0 {
+ hit_cold(key);
+ }
+
+ #[cold]
+ fn hit_cold(key: &'static str) -> () {
+ ACTIVE.with(|it| it.borrow().iter().for_each(|g| g.hit(key)))
+ }
+ }
+
+ struct GuardInner {
+ mark: &'static str,
+ hits: Cell<usize>,
+ expected_hits: Option<usize>,
+ }
+
+ pub struct Guard {
+ inner: Rc<GuardInner>,
+ }
+
+ impl GuardInner {
+ fn hit(&self, key: &'static str) {
+ if key == self.mark {
+ self.hits.set(self.hits.get().saturating_add(1))
+ }
+ }
+ }
+
+ impl Guard {
+ pub fn new(mark: &'static str, expected_hits: Option<usize>) -> Guard {
+ let inner = GuardInner {
+ mark,
+ hits: Cell::new(0),
+ expected_hits,
+ };
+ let inner = Rc::new(inner);
+ LEVEL.fetch_add(1, Relaxed);
+ ACTIVE.with(|it| it.borrow_mut().push(Rc::clone(&inner)));
+ Guard { inner }
+ }
+ }
+
+ impl Drop for Guard {
+ fn drop(&mut self) {
+ LEVEL.fetch_sub(1, Relaxed);
+ let last = ACTIVE.with(|it| it.borrow_mut().pop());
+
+ if std::thread::panicking() {
+ return;
+ }
+
+ let last = last.unwrap();
+ assert!(Rc::ptr_eq(&last, &self.inner));
+ let hit_count = last.hits.get();
+ match last.expected_hits {
+ Some(hits) => assert!(
+ hit_count == hits,
+ "mark was hit {} times, expected {}",
+ hit_count,
+ hits
+ ),
+ None => assert!(hit_count > 0, "mark was not hit"),
+ }
+ }
+ }
+}
+
+#[doc(hidden)]
+#[cfg(not(feature = "enable"))]
+pub mod __rt {
+ #[inline(always)]
+ pub fn hit(_: &'static str) {}
+
+ #[non_exhaustive]
+ pub struct Guard;
+
+ impl Guard {
+ pub fn new(_: &'static str, _: Option<usize>) -> Guard {
+ Guard
+ }
+ }
+}
diff --git a/vendor/cov-mark/tests/smoke.rs b/vendor/cov-mark/tests/smoke.rs
new file mode 100644
index 000000000..102636a0d
--- /dev/null
+++ b/vendor/cov-mark/tests/smoke.rs
@@ -0,0 +1,27 @@
+fn safe_divide(dividend: u32, divisor: u32) -> u32 {
+ if divisor == 0 {
+ cov_mark::hit!(save_divide_zero);
+ return 0;
+ }
+ dividend / divisor
+}
+
+#[test]
+fn test_safe_divide_by_zero() {
+ cov_mark::check!(save_divide_zero);
+ assert_eq!(safe_divide(92, 0), 0);
+}
+
+struct CoveredDropper;
+impl Drop for CoveredDropper {
+ fn drop(&mut self) {
+ cov_mark::hit!(covered_dropper_drops);
+ }
+}
+
+#[test]
+fn test_drop_count() {
+ cov_mark::check_count!(covered_dropper_drops, 2);
+ let _covered_dropper1 = CoveredDropper;
+ let _covered_dropper2 = CoveredDropper;
+}