summaryrefslogtreecommitdiffstats
path: root/vendor/cpufeatures/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:21 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:18:21 +0000
commit4e8199b572f2035b7749cba276ece3a26630d23e (patch)
treef09feeed6a0fe39d027b1908aa63ea6b35e4b631 /vendor/cpufeatures/Cargo.toml
parentAdding upstream version 1.66.0+dfsg1. (diff)
downloadrustc-4e8199b572f2035b7749cba276ece3a26630d23e.tar.xz
rustc-4e8199b572f2035b7749cba276ece3a26630d23e.zip
Adding upstream version 1.67.1+dfsg1.upstream/1.67.1+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/cpufeatures/Cargo.toml')
-rw-r--r--vendor/cpufeatures/Cargo.toml21
1 files changed, 15 insertions, 6 deletions
diff --git a/vendor/cpufeatures/Cargo.toml b/vendor/cpufeatures/Cargo.toml
index f4182b123..f9fea8135 100644
--- a/vendor/cpufeatures/Cargo.toml
+++ b/vendor/cpufeatures/Cargo.toml
@@ -12,18 +12,27 @@
[package]
edition = "2018"
name = "cpufeatures"
-version = "0.2.2"
+version = "0.2.5"
authors = ["RustCrypto Developers"]
-description = "Lightweight runtime CPU feature detection for x86/x86_64 and aarch64 with\nno_std support and support for mobile targets including Android and iOS\n"
+description = """
+Lightweight runtime CPU feature detection for x86/x86_64 and aarch64 with
+no_std support and support for mobile targets including Android and iOS
+"""
documentation = "https://docs.rs/cpufeatures"
readme = "README.md"
-keywords = ["cpuid", "target-feature"]
+keywords = [
+ "cpuid",
+ "target-feature",
+]
categories = ["no-std"]
license = "MIT OR Apache-2.0"
repository = "https://github.com/RustCrypto/utils"
+
[target.aarch64-apple-darwin.dependencies.libc]
-version = "0.2.68"
+version = "0.2.95"
+
[target.aarch64-linux-android.dependencies.libc]
-version = "0.2.68"
+version = "0.2.95"
+
[target."cfg(all(target_arch = \"aarch64\", target_os = \"linux\"))".dependencies.libc]
-version = "0.2.68"
+version = "0.2.95"