summaryrefslogtreecommitdiffstats
path: root/vendor/cpufeatures/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/cpufeatures/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/cpufeatures/Cargo.toml')
-rw-r--r--vendor/cpufeatures/Cargo.toml29
1 files changed, 29 insertions, 0 deletions
diff --git a/vendor/cpufeatures/Cargo.toml b/vendor/cpufeatures/Cargo.toml
new file mode 100644
index 000000000..f4182b123
--- /dev/null
+++ b/vendor/cpufeatures/Cargo.toml
@@ -0,0 +1,29 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "cpufeatures"
+version = "0.2.2"
+authors = ["RustCrypto Developers"]
+description = "Lightweight runtime CPU feature detection for x86/x86_64 and aarch64 with\nno_std support and support for mobile targets including Android and iOS\n"
+documentation = "https://docs.rs/cpufeatures"
+readme = "README.md"
+keywords = ["cpuid", "target-feature"]
+categories = ["no-std"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/RustCrypto/utils"
+[target.aarch64-apple-darwin.dependencies.libc]
+version = "0.2.68"
+[target.aarch64-linux-android.dependencies.libc]
+version = "0.2.68"
+[target."cfg(all(target_arch = \"aarch64\", target_os = \"linux\"))".dependencies.libc]
+version = "0.2.68"