summaryrefslogtreecommitdiffstats
path: root/vendor/curl/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:35 +0000
commit7e5d7eea9c580ef4b41a765bde624af431942b96 (patch)
tree2c0d9ca12878fc4525650aa4e54d77a81a07cc09 /vendor/curl/Cargo.toml
parentAdding debian version 1.70.0+dfsg1-9. (diff)
downloadrustc-7e5d7eea9c580ef4b41a765bde624af431942b96.tar.xz
rustc-7e5d7eea9c580ef4b41a765bde624af431942b96.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/curl/Cargo.toml')
-rw-r--r--vendor/curl/Cargo.toml124
1 files changed, 124 insertions, 0 deletions
diff --git a/vendor/curl/Cargo.toml b/vendor/curl/Cargo.toml
new file mode 100644
index 000000000..bfb59f457
--- /dev/null
+++ b/vendor/curl/Cargo.toml
@@ -0,0 +1,124 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "curl"
+version = "0.4.44"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+autotests = true
+description = "Rust bindings to libcurl for making HTTP requests"
+homepage = "https://github.com/alexcrichton/curl-rust"
+documentation = "https://docs.rs/curl"
+readme = "README.md"
+categories = [
+ "api-bindings",
+ "web-programming::http-client",
+]
+license = "MIT"
+repository = "https://github.com/alexcrichton/curl-rust"
+
+[[example]]
+name = "https"
+path = "examples/https.rs"
+
+[[example]]
+name = "ssl_proxy"
+path = "examples/ssl_proxy.rs"
+required-features = ["ssl"]
+
+[[example]]
+name = "ssl_cert_blob"
+path = "examples/ssl_cert_blob.rs"
+required-features = ["ssl"]
+
+[[example]]
+name = "aws_sigv4"
+path = "examples/aws_sigv4.rs"
+required-features = [
+ "static-curl",
+ "ssl",
+]
+
+[[example]]
+name = "multi-dl"
+path = "examples/multi-dl.rs"
+required-features = ["ssl"]
+
+[[test]]
+name = "atexit"
+harness = false
+
+[dependencies.curl-sys]
+version = "0.4.56"
+default-features = false
+
+[dependencies.libc]
+version = "0.2.42"
+
+[dependencies.socket2]
+version = "0.4.0"
+
+[dev-dependencies.anyhow]
+version = "1.0.31"
+
+[dev-dependencies.mio]
+version = "0.6"
+
+[dev-dependencies.mio-extras]
+version = "2.0.3"
+
+[features]
+default = ["ssl"]
+force-system-lib-on-osx = ["curl-sys/force-system-lib-on-osx"]
+http2 = ["curl-sys/http2"]
+mesalink = ["curl-sys/mesalink"]
+ntlm = ["curl-sys/ntlm"]
+poll_7_68_0 = ["curl-sys/poll_7_68_0"]
+protocol-ftp = ["curl-sys/protocol-ftp"]
+rustls = ["curl-sys/rustls"]
+spnego = ["curl-sys/spnego"]
+ssl = [
+ "openssl-sys",
+ "openssl-probe",
+ "curl-sys/ssl",
+]
+static-curl = ["curl-sys/static-curl"]
+static-ssl = ["curl-sys/static-ssl"]
+upkeep_7_62_0 = ["curl-sys/upkeep_7_62_0"]
+zlib-ng-compat = [
+ "curl-sys/zlib-ng-compat",
+ "static-curl",
+]
+
+[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-probe]
+version = "0.1.2"
+optional = true
+
+[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys]
+version = "0.9.43"
+optional = true
+
+[target."cfg(target_env = \"msvc\")".dependencies.schannel]
+version = "0.1.13"
+
+[target."cfg(target_env = \"msvc\")".dependencies.winapi]
+version = "0.3"
+features = [
+ "libloaderapi",
+ "wincrypt",
+]
+
+[badges.appveyor]
+repository = "alexcrichton/curl-rust"
+
+[badges.travis-ci]
+repository = "alexcrichton/curl-rust"