summaryrefslogtreecommitdiffstats
path: root/vendor/cxx-build/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
commit837b550238aa671a591ccf282dddeab29cadb206 (patch)
tree914b6b8862bace72bd3245ca184d374b08d8a672 /vendor/cxx-build/Cargo.toml
parentAdding debian version 1.70.0+dfsg2-1. (diff)
downloadrustc-837b550238aa671a591ccf282dddeab29cadb206.tar.xz
rustc-837b550238aa671a591ccf282dddeab29cadb206.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/cxx-build/Cargo.toml')
-rw-r--r--vendor/cxx-build/Cargo.toml81
1 files changed, 81 insertions, 0 deletions
diff --git a/vendor/cxx-build/Cargo.toml b/vendor/cxx-build/Cargo.toml
new file mode 100644
index 000000000..6423fde08
--- /dev/null
+++ b/vendor/cxx-build/Cargo.toml
@@ -0,0 +1,81 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.60"
+name = "cxx-build"
+version = "1.0.94"
+authors = ["David Tolnay <dtolnay@gmail.com>"]
+exclude = ["build.rs"]
+description = "C++ code generator for integrating `cxx` crate into a Cargo build."
+homepage = "https://cxx.rs"
+documentation = "https://docs.rs/cxx-build"
+keywords = [
+ "ffi",
+ "build-dependencies",
+]
+categories = [
+ "development-tools::build-utils",
+ "development-tools::ffi",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/dtolnay/cxx"
+
+[package.metadata.docs.rs]
+targets = ["x86_64-unknown-linux-gnu"]
+
+[lib]
+doc-scrape-examples = false
+
+[dependencies.cc]
+version = "1.0.49"
+
+[dependencies.codespan-reporting]
+version = "0.11.1"
+
+[dependencies.once_cell]
+version = "1.9"
+
+[dependencies.proc-macro2]
+version = "1.0.39"
+features = ["span-locations"]
+default-features = false
+
+[dependencies.quote]
+version = "1.0"
+default-features = false
+
+[dependencies.scratch]
+version = "1.0"
+
+[dependencies.syn]
+version = "2.0.1"
+features = [
+ "parsing",
+ "printing",
+ "clone-impls",
+ "full",
+]
+default-features = false
+
+[dev-dependencies.cxx]
+version = "1.0"
+
+[dev-dependencies.cxx-gen]
+version = "0.7"
+
+[dev-dependencies.pkg-config]
+version = "0.3"
+
+[features]
+experimental-async-fn = []
+parallel = ["cc/parallel"]