summaryrefslogtreecommitdiffstats
path: root/vendor/dashmap/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/dashmap/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/dashmap/Cargo.toml')
-rw-r--r--vendor/dashmap/Cargo.toml51
1 files changed, 51 insertions, 0 deletions
diff --git a/vendor/dashmap/Cargo.toml b/vendor/dashmap/Cargo.toml
new file mode 100644
index 000000000..a03feb0ce
--- /dev/null
+++ b/vendor/dashmap/Cargo.toml
@@ -0,0 +1,51 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.59"
+name = "dashmap"
+version = "5.3.4"
+authors = ["Acrimon <joel.wejdenstal@gmail.com>"]
+description = "Blazing fast concurrent HashMap for Rust."
+homepage = "https://github.com/xacrimon/dashmap"
+documentation = "https://docs.rs/dashmap"
+readme = "README.md"
+keywords = ["atomic", "concurrent", "hashmap"]
+categories = ["concurrency", "algorithms", "data-structures"]
+license = "MIT"
+repository = "https://github.com/xacrimon/dashmap"
+[package.metadata.docs.rs]
+features = ["rayon", "raw-api", "serde"]
+[dependencies.cfg-if]
+version = "1.0.0"
+
+[dependencies.hashbrown]
+version = "0.12.0"
+default-features = false
+
+[dependencies.lock_api]
+version = "0.4.7"
+
+[dependencies.parking_lot_core]
+version = "0.9.3"
+
+[dependencies.rayon]
+version = "1.5.2"
+optional = true
+
+[dependencies.serde]
+version = "1.0.136"
+features = ["derive"]
+optional = true
+
+[features]
+raw-api = []