summaryrefslogtreecommitdiffstats
path: root/vendor/elasticlunr-rs/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/elasticlunr-rs/Cargo.toml
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/elasticlunr-rs/Cargo.toml')
-rw-r--r--vendor/elasticlunr-rs/Cargo.toml86
1 files changed, 86 insertions, 0 deletions
diff --git a/vendor/elasticlunr-rs/Cargo.toml b/vendor/elasticlunr-rs/Cargo.toml
new file mode 100644
index 000000000..10e0d8411
--- /dev/null
+++ b/vendor/elasticlunr-rs/Cargo.toml
@@ -0,0 +1,86 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+rust-version = "1.54"
+name = "elasticlunr-rs"
+version = "3.0.0"
+authors = ["Matt Ickstadt <mattico8@gmail.com>"]
+exclude = ["tests/lunr-fixture-gen/**", "js/**"]
+description = "A partial port of elasticlunr.js to Rust for generating static document search indexes"
+documentation = "https://docs.rs/elasticlunr-rs"
+readme = "README.md"
+keywords = ["search", "index", "indexing", "lunr", "elasticlunr"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/mattico/elasticlunr-rs"
+
+[lib]
+name = "elasticlunr"
+
+[[bench]]
+name = "bench"
+harness = false
+[dependencies.jieba-rs]
+version = "0.6"
+optional = true
+
+[dependencies.lindera]
+version = "0.13"
+features = ["ipadic"]
+optional = true
+
+[dependencies.lindera-core]
+version = "0.13"
+optional = true
+
+[dependencies.regex]
+version = "1"
+
+[dependencies.rust-stemmers]
+version = "1.2.0"
+optional = true
+
+[dependencies.serde]
+version = "1"
+
+[dependencies.serde_derive]
+version = "1.0.34"
+
+[dependencies.serde_json]
+version = "1"
+[dev-dependencies.criterion]
+version = "0.3.0"
+
+[dev-dependencies.maplit]
+version = "1"
+
+[features]
+ar = []
+da = ["rust-stemmers"]
+de = ["rust-stemmers"]
+du = ["rust-stemmers"]
+es = ["rust-stemmers"]
+fi = ["rust-stemmers"]
+fr = ["rust-stemmers"]
+it = ["rust-stemmers"]
+ja = ["lindera", "lindera-core"]
+languages = ["ar", "da", "de", "du", "es", "fi", "fr", "it", "ja", "no", "pt", "ro", "ru", "sv", "tr", "zh"]
+no = ["rust-stemmers"]
+pt = ["rust-stemmers"]
+ro = ["rust-stemmers"]
+ru = ["rust-stemmers"]
+sv = ["rust-stemmers"]
+tr = ["rust-stemmers"]
+zh = ["jieba-rs"]
+[badges.maintenance]
+status = "passively-maintained"