summaryrefslogtreecommitdiffstats
path: root/vendor/errno/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:29 +0000
commit631cd5845e8de329d0e227aaa707d7ea228b8f8f (patch)
treea1b87c8f8cad01cf18f7c5f57a08f102771ed303 /vendor/errno/Cargo.toml
parentAdding debian version 1.69.0+dfsg1-1. (diff)
downloadrustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.tar.xz
rustc-631cd5845e8de329d0e227aaa707d7ea228b8f8f.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/errno/Cargo.toml')
-rw-r--r--vendor/errno/Cargo.toml26
1 files changed, 20 insertions, 6 deletions
diff --git a/vendor/errno/Cargo.toml b/vendor/errno/Cargo.toml
index 2349617b0..98668cb9b 100644
--- a/vendor/errno/Cargo.toml
+++ b/vendor/errno/Cargo.toml
@@ -10,26 +10,40 @@
# See Cargo.toml.orig for the original contents.
[package]
+edition = "2018"
+rust-version = "1.48"
name = "errno"
-version = "0.2.8"
+version = "0.3.0"
authors = ["Chris Wong <lambda.fairy@gmail.com>"]
description = "Cross-platform interface to the `errno` variable."
documentation = "https://docs.rs/errno"
-categories = ["os"]
-license = "MIT/Apache-2.0"
+readme = "README.md"
+categories = [
+ "no-std",
+ "os",
+]
+license = "MIT OR Apache-2.0"
repository = "https://github.com/lambda-fairy/rust-errno"
[features]
default = ["std"]
std = []
+
[target."cfg(target_os=\"dragonfly\")".dependencies.errno-dragonfly]
version = "0.1.1"
+
[target."cfg(target_os=\"hermit\")".dependencies.libc]
version = "0.2"
+
[target."cfg(target_os=\"wasi\")".dependencies.libc]
version = "0.2"
+
[target."cfg(unix)".dependencies.libc]
version = "0.2"
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = ["errhandlingapi", "minwindef", "ntdef", "winbase"]
+
+[target."cfg(windows)".dependencies.windows-sys]
+version = "0.45"
+features = [
+ "Win32_Foundation",
+ "Win32_System_Diagnostics_Debug",
+]