summaryrefslogtreecommitdiffstats
path: root/vendor/errno/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/errno/README.md
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/errno/README.md')
-rw-r--r--vendor/errno/README.md38
1 files changed, 38 insertions, 0 deletions
diff --git a/vendor/errno/README.md b/vendor/errno/README.md
new file mode 100644
index 000000000..a4762a7d0
--- /dev/null
+++ b/vendor/errno/README.md
@@ -0,0 +1,38 @@
+# errno [![CI](https://github.com/lambda-fairy/rust-errno/actions/workflows/main.yml/badge.svg)](https://github.com/lambda-fairy/rust-errno/actions/workflows/main.yml) [![Cargo](https://img.shields.io/crates/v/errno.svg)](https://crates.io/crates/errno)
+
+Cross-platform interface to the [`errno`][errno] variable. Works on Rust 1.13 or newer.
+
+Documentation is available at <https://docs.rs/errno>.
+
+[errno]: https://en.wikipedia.org/wiki/Errno.h
+
+
+## Dependency
+
+Add to your `Cargo.toml`:
+
+```toml
+[dependencies]
+errno = "*"
+libc = "*"
+```
+
+
+## Examples
+
+```rust
+extern crate errno;
+use errno::{Errno, errno, set_errno};
+
+// Get the current value of errno
+let e = errno();
+
+// Set the current value of errno
+set_errno(e);
+
+// Extract the error code as an i32
+let code = e.0;
+
+// Display a human-friendly error message
+println!("Error {}: {}", code, e);
+```