summaryrefslogtreecommitdiffstats
path: root/vendor/errno
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
commitef24de24a82fe681581cc130f342363c47c0969a (patch)
tree0d494f7e1a38b95c92426f58fe6eaa877303a86c /vendor/errno
parentReleasing progress-linux version 1.74.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-ef24de24a82fe681581cc130f342363c47c0969a.tar.xz
rustc-ef24de24a82fe681581cc130f342363c47c0969a.zip
Merging upstream version 1.75.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--vendor/errno-dragonfly/.cargo-checksum.json1
-rw-r--r--vendor/errno-dragonfly/Cargo.toml27
-rw-r--r--vendor/errno-dragonfly/LICENSE21
-rw-r--r--vendor/errno-dragonfly/README.md3
-rw-r--r--vendor/errno-dragonfly/build.rs3
-rw-r--r--vendor/errno-dragonfly/src/errno.c3
-rw-r--r--vendor/errno-dragonfly/src/lib.rs6
-rw-r--r--vendor/errno/.cargo-checksum.json2
-rw-r--r--vendor/errno/CHANGELOG.md35
-rw-r--r--vendor/errno/Cargo.toml10
-rw-r--r--vendor/errno/src/hermit.rs2
-rw-r--r--vendor/errno/src/unix.rs19
12 files changed, 54 insertions, 78 deletions
diff --git a/vendor/errno-dragonfly/.cargo-checksum.json b/vendor/errno-dragonfly/.cargo-checksum.json
deleted file mode 100644
index 2579ff65f..000000000
--- a/vendor/errno-dragonfly/.cargo-checksum.json
+++ /dev/null
@@ -1 +0,0 @@
-{"files":{"Cargo.toml":"36cf2ca7d85e09d22a7dd384f95c51eb6a7f1a6234d3c54d251dfa575b990430","LICENSE":"e5b1e4fcd8ea2b20b09f378e44ef3f51f4b6a72a72b9f6a729e0f87bddcef97f","README.md":"1e8440a65b6befd65a507b60fb11ab29f314dd77012aa7a11b5d1fadbb5f908f","build.rs":"10d4f05ac56556fea0e98732dc4250ddf3f1acc3fea541c63a0bc130aca772e6","src/errno.c":"a857e47b114acb85fddcb252a610ab5734d225c26b7bedd7c35d7789d46c8526","src/lib.rs":"47245dcfc2d5797584444e70edb1997b2f5e39ecc0779599a7fcded379966c0f"},"package":"aa68f1b12764fab894d2755d2518754e71b4fd80ecfb822714a1206c2aab39bf"} \ No newline at end of file
diff --git a/vendor/errno-dragonfly/Cargo.toml b/vendor/errno-dragonfly/Cargo.toml
deleted file mode 100644
index 51e21437b..000000000
--- a/vendor/errno-dragonfly/Cargo.toml
+++ /dev/null
@@ -1,27 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
-#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
-
-[package]
-edition = "2018"
-name = "errno-dragonfly"
-version = "0.1.2"
-authors = ["Michael Neumann <mneumann@ntecs.de>"]
-include = ["Cargo.toml", "LICENSE", "README.md", "build.rs", "src/lib.rs", "src/errno.c"]
-description = "Exposes errno functionality to stable Rust on DragonFlyBSD"
-keywords = ["dragonfly"]
-license = "MIT"
-repository = "https://github.com/mneumann/errno-dragonfly-rs"
-[dependencies.libc]
-version = "0.2"
-default-features = false
-[build-dependencies.cc]
-version = "1.0"
diff --git a/vendor/errno-dragonfly/LICENSE b/vendor/errno-dragonfly/LICENSE
deleted file mode 100644
index 1f1500c81..000000000
--- a/vendor/errno-dragonfly/LICENSE
+++ /dev/null
@@ -1,21 +0,0 @@
-MIT License
-
-Copyright (c) 2017 Michael Neumann
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in all
-copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-SOFTWARE.
diff --git a/vendor/errno-dragonfly/README.md b/vendor/errno-dragonfly/README.md
deleted file mode 100644
index 9218a7b88..000000000
--- a/vendor/errno-dragonfly/README.md
+++ /dev/null
@@ -1,3 +0,0 @@
-# errno-dragonfly-rs
-
-Exposing `errno` functionality to stable Rust on DragonFly BSD.
diff --git a/vendor/errno-dragonfly/build.rs b/vendor/errno-dragonfly/build.rs
deleted file mode 100644
index b93b9ef87..000000000
--- a/vendor/errno-dragonfly/build.rs
+++ /dev/null
@@ -1,3 +0,0 @@
-fn main() {
- cc::Build::new().file("src/errno.c").compile("liberrno.a");
-}
diff --git a/vendor/errno-dragonfly/src/errno.c b/vendor/errno-dragonfly/src/errno.c
deleted file mode 100644
index 32fb4dab4..000000000
--- a/vendor/errno-dragonfly/src/errno.c
+++ /dev/null
@@ -1,3 +0,0 @@
-#include <errno.h>
-
-int *errno_location() { return &errno; }
diff --git a/vendor/errno-dragonfly/src/lib.rs b/vendor/errno-dragonfly/src/lib.rs
deleted file mode 100644
index 4208344d3..000000000
--- a/vendor/errno-dragonfly/src/lib.rs
+++ /dev/null
@@ -1,6 +0,0 @@
-#![no_std]
-
-#[link(name = "errno", kind = "static")]
-extern "C" {
- pub fn errno_location() -> *mut libc::c_int;
-}
diff --git a/vendor/errno/.cargo-checksum.json b/vendor/errno/.cargo-checksum.json
index 93f00ae56..15c4378d0 100644
--- a/vendor/errno/.cargo-checksum.json
+++ b/vendor/errno/.cargo-checksum.json
@@ -1 +1 @@
-{"files":{"CHANGELOG.md":"de0a0148de26643113bc5a65e6954ecbd92ba99abc694da4944c7495cfd92b66","Cargo.toml":"7148d6f70b6070cb1b5714143c9695189121619232eafdef9bd0d5b7dbc3e930","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"8764a597675778ddfd4e25f81b08a05dbcf089ac05662df7613fe67f150e3aa2","README.md":"96a40903ea0fe68cf512d176a230f4a37df76de262f047f01a46f31de75402bd","clippy.toml":"2c27890fbf0454bb2405bdb013b1daeb78d57c5844b964bcac9afcc125fa46e4","src/hermit.rs":"a0d6839cbef77e2e93acafc629c76805b858311982f19b99c3389e43cfbebfbf","src/lib.rs":"318f864b8cb9296c85f70f9dfb855c552303630b3a9390f147bb4b581b8d8b5c","src/unix.rs":"6b884aad20e0bc015ec3a99c2f48c886345533fd92787c3b18742654071b7741","src/wasi.rs":"c606886ebda52b5dc7682c0f3aaf51e146692455acd5e303812cf0d634589d05","src/windows.rs":"7cbcdb8e74582f357fa945bb1c44c4d19c1a10bec958da1223305bf68ec35baf"},"package":"4bcfec3a70f97c962c307b2d2c56e358cf1d00b558d74262b5f929ee8cc7e73a"} \ No newline at end of file
+{"files":{"CHANGELOG.md":"0e7e9b66ccefbe89e04196022c35a799cd6cd9399fc72935efab6b76544d89cc","Cargo.toml":"a93ea470beb86eabc94f7a4bacc40d7837b336a77dc8c02317da75c26386ad88","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"8764a597675778ddfd4e25f81b08a05dbcf089ac05662df7613fe67f150e3aa2","README.md":"96a40903ea0fe68cf512d176a230f4a37df76de262f047f01a46f31de75402bd","clippy.toml":"2c27890fbf0454bb2405bdb013b1daeb78d57c5844b964bcac9afcc125fa46e4","src/hermit.rs":"ad03355bc4d79c180ab3210e1d3edd538eccaaea8d4f9a9b7eb8a0dc2d39b5df","src/lib.rs":"318f864b8cb9296c85f70f9dfb855c552303630b3a9390f147bb4b581b8d8b5c","src/unix.rs":"dc11866f338b4b40ebafb3fc8a2ac7079ea932fe8090d9cae37e4b10d97fca5a","src/wasi.rs":"c606886ebda52b5dc7682c0f3aaf51e146692455acd5e303812cf0d634589d05","src/windows.rs":"7cbcdb8e74582f357fa945bb1c44c4d19c1a10bec958da1223305bf68ec35baf"},"package":"ac3e13f66a2f95e32a39eaa81f6b95d42878ca0e1db0c7543723dfe12557e860"} \ No newline at end of file
diff --git a/vendor/errno/CHANGELOG.md b/vendor/errno/CHANGELOG.md
index 0c8f3daca..fa43eec6e 100644
--- a/vendor/errno/CHANGELOG.md
+++ b/vendor/errno/CHANGELOG.md
@@ -1,5 +1,34 @@
# [Unreleased]
+# [0.3.5] - 2023-10-08
+
+- Use __errno_location on DragonFly BSD
+ [#82](https://github.com/lambda-fairy/rust-errno/pull/82)
+
+# [0.3.4] - 2023-10-01
+
+- Add GNU/Hurd support
+ [#80](https://github.com/lambda-fairy/rust-errno/pull/80)
+
+# [0.3.3] - 2023-08-28
+
+- Disable "libc/std" in no-std configurations.
+ [#77](https://github.com/lambda-fairy/rust-errno/pull/77)
+
+- Bump errno-dragonfly to 0.1.2
+ [#75](https://github.com/lambda-fairy/rust-errno/pull/75)
+
+- Support for the ESP-IDF framework
+ [#74](https://github.com/lambda-fairy/rust-errno/pull/74)
+
+# [0.3.2] - 2023-07-30
+
+- Fix build on Hermit
+ [#73](https://github.com/lambda-fairy/rust-errno/pull/73)
+
+- Add support for QNX Neutrino
+ [#72](https://github.com/lambda-fairy/rust-errno/pull/72)
+
# [0.3.1] - 2023-04-08
- Correct link name on redox
@@ -33,7 +62,11 @@
- Optionally support no_std
[#31](https://github.com/lambda-fairy/rust-errno/pull/31)
-[Unreleased]: https://github.com/lambda-fairy/rust-errno/compare/v0.3.1...HEAD
+[Unreleased]: https://github.com/lambda-fairy/rust-errno/compare/v0.3.5...HEAD
+[0.3.5]: https://github.com/lambda-fairy/rust-errno/compare/v0.3.4...v0.3.5
+[0.3.4]: https://github.com/lambda-fairy/rust-errno/compare/v0.3.3...v0.3.4
+[0.3.3]: https://github.com/lambda-fairy/rust-errno/compare/v0.3.2...v0.3.3
+[0.3.2]: https://github.com/lambda-fairy/rust-errno/compare/v0.3.1...v0.3.2
[0.3.1]: https://github.com/lambda-fairy/rust-errno/compare/v0.3.0...v0.3.1
[0.3.0]: https://github.com/lambda-fairy/rust-errno/compare/v0.2.8...v0.3.0
[0.2.8]: https://github.com/lambda-fairy/rust-errno/compare/v0.2.7...v0.2.8
diff --git a/vendor/errno/Cargo.toml b/vendor/errno/Cargo.toml
index bf54b1f46..d35ef19cd 100644
--- a/vendor/errno/Cargo.toml
+++ b/vendor/errno/Cargo.toml
@@ -13,7 +13,7 @@
edition = "2018"
rust-version = "1.48"
name = "errno"
-version = "0.3.1"
+version = "0.3.5"
authors = ["Chris Wong <lambda.fairy@gmail.com>"]
description = "Cross-platform interface to the `errno` variable."
documentation = "https://docs.rs/errno"
@@ -27,19 +27,19 @@ repository = "https://github.com/lambda-fairy/rust-errno"
[features]
default = ["std"]
-std = []
-
-[target."cfg(target_os=\"dragonfly\")".dependencies.errno-dragonfly]
-version = "0.1.1"
+std = ["libc/std"]
[target."cfg(target_os=\"hermit\")".dependencies.libc]
version = "0.2"
+default-features = false
[target."cfg(target_os=\"wasi\")".dependencies.libc]
version = "0.2"
+default-features = false
[target."cfg(unix)".dependencies.libc]
version = "0.2"
+default-features = false
[target."cfg(windows)".dependencies.windows-sys]
version = "0.48"
diff --git a/vendor/errno/src/hermit.rs b/vendor/errno/src/hermit.rs
index 99d4c3286..331b6b152 100644
--- a/vendor/errno/src/hermit.rs
+++ b/vendor/errno/src/hermit.rs
@@ -14,7 +14,7 @@
// option. This file may not be copied, modified, or distributed
// except according to those terms.
-use Errno;
+use crate::Errno;
pub fn with_description<F, T>(_err: Errno, callback: F) -> T
where
diff --git a/vendor/errno/src/unix.rs b/vendor/errno/src/unix.rs
index 2f0286000..86a35d9be 100644
--- a/vendor/errno/src/unix.rs
+++ b/vendor/errno/src/unix.rs
@@ -13,8 +13,6 @@
// except according to those terms.
use core::str;
-#[cfg(target_os = "dragonfly")]
-use errno_dragonfly::errno_location;
use libc::{self, c_char, c_int, size_t, strlen};
use crate::Errno;
@@ -57,7 +55,6 @@ pub fn set_errno(Errno(errno): Errno) {
}
extern "C" {
- #[cfg(not(target_os = "dragonfly"))]
#[cfg_attr(
any(target_os = "macos", target_os = "ios", target_os = "freebsd"),
link_name = "__error"
@@ -67,7 +64,8 @@ extern "C" {
target_os = "openbsd",
target_os = "netbsd",
target_os = "bitrig",
- target_os = "android"
+ target_os = "android",
+ target_os = "espidf"
),
link_name = "__errno"
)]
@@ -77,12 +75,21 @@ extern "C" {
)]
#[cfg_attr(target_os = "haiku", link_name = "_errnop")]
#[cfg_attr(
- any(target_os = "linux", target_os = "redox"),
+ any(
+ target_os = "linux",
+ target_os = "hurd",
+ target_os = "redox",
+ target_os = "dragonfly"
+ ),
link_name = "__errno_location"
)]
#[cfg_attr(target_os = "aix", link_name = "_Errno")]
+ #[cfg_attr(target_os = "nto", link_name = "__get_errno_ptr")]
fn errno_location() -> *mut c_int;
- #[cfg_attr(target_os = "linux", link_name = "__xpg_strerror_r")]
+ #[cfg_attr(
+ any(target_os = "linux", target_os = "hurd"),
+ link_name = "__xpg_strerror_r"
+ )]
fn strerror_r(errnum: c_int, buf: *mut c_char, buflen: size_t) -> c_int;
}