summaryrefslogtreecommitdiffstats
path: root/vendor/errno
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:42 +0000
commit837b550238aa671a591ccf282dddeab29cadb206 (patch)
tree914b6b8862bace72bd3245ca184d374b08d8a672 /vendor/errno
parentAdding debian version 1.70.0+dfsg2-1. (diff)
downloadrustc-837b550238aa671a591ccf282dddeab29cadb206.tar.xz
rustc-837b550238aa671a591ccf282dddeab29cadb206.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/errno')
-rw-r--r--vendor/errno/.cargo-checksum.json2
-rw-r--r--vendor/errno/CHANGELOG.md11
-rw-r--r--vendor/errno/Cargo.toml4
-rw-r--r--vendor/errno/src/unix.rs5
4 files changed, 17 insertions, 5 deletions
diff --git a/vendor/errno/.cargo-checksum.json b/vendor/errno/.cargo-checksum.json
index 40940cedb..93f00ae56 100644
--- a/vendor/errno/.cargo-checksum.json
+++ b/vendor/errno/.cargo-checksum.json
@@ -1 +1 @@
-{"files":{"CHANGELOG.md":"80348d2f4e4e309a65c6e1db88234e596fe7aef1be04b33079b3f580fa1ba7bb","Cargo.toml":"9c2bdda2209a38b52cba3f9fb9286a109d765f3301fae47b6427c134be7bb0de","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"8764a597675778ddfd4e25f81b08a05dbcf089ac05662df7613fe67f150e3aa2","README.md":"96a40903ea0fe68cf512d176a230f4a37df76de262f047f01a46f31de75402bd","clippy.toml":"2c27890fbf0454bb2405bdb013b1daeb78d57c5844b964bcac9afcc125fa46e4","src/hermit.rs":"a0d6839cbef77e2e93acafc629c76805b858311982f19b99c3389e43cfbebfbf","src/lib.rs":"318f864b8cb9296c85f70f9dfb855c552303630b3a9390f147bb4b581b8d8b5c","src/unix.rs":"fa6f6f615136ff2cad78d11f0b8396705a03dc9991af8a0389ab95b14537c44d","src/wasi.rs":"c606886ebda52b5dc7682c0f3aaf51e146692455acd5e303812cf0d634589d05","src/windows.rs":"7cbcdb8e74582f357fa945bb1c44c4d19c1a10bec958da1223305bf68ec35baf"},"package":"50d6a0976c999d473fe89ad888d5a284e55366d9dc9038b1ba2aa15128c4afa0"} \ No newline at end of file
+{"files":{"CHANGELOG.md":"de0a0148de26643113bc5a65e6954ecbd92ba99abc694da4944c7495cfd92b66","Cargo.toml":"7148d6f70b6070cb1b5714143c9695189121619232eafdef9bd0d5b7dbc3e930","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"8764a597675778ddfd4e25f81b08a05dbcf089ac05662df7613fe67f150e3aa2","README.md":"96a40903ea0fe68cf512d176a230f4a37df76de262f047f01a46f31de75402bd","clippy.toml":"2c27890fbf0454bb2405bdb013b1daeb78d57c5844b964bcac9afcc125fa46e4","src/hermit.rs":"a0d6839cbef77e2e93acafc629c76805b858311982f19b99c3389e43cfbebfbf","src/lib.rs":"318f864b8cb9296c85f70f9dfb855c552303630b3a9390f147bb4b581b8d8b5c","src/unix.rs":"6b884aad20e0bc015ec3a99c2f48c886345533fd92787c3b18742654071b7741","src/wasi.rs":"c606886ebda52b5dc7682c0f3aaf51e146692455acd5e303812cf0d634589d05","src/windows.rs":"7cbcdb8e74582f357fa945bb1c44c4d19c1a10bec958da1223305bf68ec35baf"},"package":"4bcfec3a70f97c962c307b2d2c56e358cf1d00b558d74262b5f929ee8cc7e73a"} \ No newline at end of file
diff --git a/vendor/errno/CHANGELOG.md b/vendor/errno/CHANGELOG.md
index 5f593190c..0c8f3daca 100644
--- a/vendor/errno/CHANGELOG.md
+++ b/vendor/errno/CHANGELOG.md
@@ -1,5 +1,13 @@
# [Unreleased]
+# [0.3.1] - 2023-04-08
+
+- Correct link name on redox
+ [#69](https://github.com/lambda-fairy/rust-errno/pull/69)
+
+- Update windows-sys requirement from 0.45 to 0.48
+ [#70](https://github.com/lambda-fairy/rust-errno/pull/70)
+
# [0.3.0] - 2023-02-12
- Add haiku support
@@ -25,6 +33,7 @@
- Optionally support no_std
[#31](https://github.com/lambda-fairy/rust-errno/pull/31)
-[Unreleased]: https://github.com/lambda-fairy/rust-errno/compare/v0.3.0...HEAD
+[Unreleased]: https://github.com/lambda-fairy/rust-errno/compare/v0.3.1...HEAD
+[0.3.1]: https://github.com/lambda-fairy/rust-errno/compare/v0.3.0...v0.3.1
[0.3.0]: https://github.com/lambda-fairy/rust-errno/compare/v0.2.8...v0.3.0
[0.2.8]: https://github.com/lambda-fairy/rust-errno/compare/v0.2.7...v0.2.8
diff --git a/vendor/errno/Cargo.toml b/vendor/errno/Cargo.toml
index 98668cb9b..bf54b1f46 100644
--- a/vendor/errno/Cargo.toml
+++ b/vendor/errno/Cargo.toml
@@ -13,7 +13,7 @@
edition = "2018"
rust-version = "1.48"
name = "errno"
-version = "0.3.0"
+version = "0.3.1"
authors = ["Chris Wong <lambda.fairy@gmail.com>"]
description = "Cross-platform interface to the `errno` variable."
documentation = "https://docs.rs/errno"
@@ -42,7 +42,7 @@ version = "0.2"
version = "0.2"
[target."cfg(windows)".dependencies.windows-sys]
-version = "0.45"
+version = "0.48"
features = [
"Win32_Foundation",
"Win32_System_Diagnostics_Debug",
diff --git a/vendor/errno/src/unix.rs b/vendor/errno/src/unix.rs
index c22c587c2..2f0286000 100644
--- a/vendor/errno/src/unix.rs
+++ b/vendor/errno/src/unix.rs
@@ -76,7 +76,10 @@ extern "C" {
link_name = "___errno"
)]
#[cfg_attr(target_os = "haiku", link_name = "_errnop")]
- #[cfg_attr(target_os = "linux", link_name = "__errno_location")]
+ #[cfg_attr(
+ any(target_os = "linux", target_os = "redox"),
+ link_name = "__errno_location"
+ )]
#[cfg_attr(target_os = "aix", link_name = "_Errno")]
fn errno_location() -> *mut c_int;