summaryrefslogtreecommitdiffstats
path: root/vendor/fs-err/CHANGELOG.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/fs-err/CHANGELOG.md
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/fs-err/CHANGELOG.md')
-rw-r--r--vendor/fs-err/CHANGELOG.md51
1 files changed, 51 insertions, 0 deletions
diff --git a/vendor/fs-err/CHANGELOG.md b/vendor/fs-err/CHANGELOG.md
new file mode 100644
index 000000000..bc973e22c
--- /dev/null
+++ b/vendor/fs-err/CHANGELOG.md
@@ -0,0 +1,51 @@
+# fs-err Changelog
+
+## 2.5.0
+* Added `symlink` for unix platforms
+* Added `symlink_file` and `symlink_dir` for windows
+* Implemented os-specific extension traits for `File`
+ - `std::os::unix::io::{AsRawFd, IntoRawFd}`
+ - `std::os::windows::io::{AsRawHandle, IntoRawHandle}`
+ - Added trait wrappers for `std::os::{unix, windows}::fs::FileExt` and implemented them for `fs_err::File`
+* Implemented os-specific extension traits for `OpenOptions`
+ - Added trait wrappers for `std::os::{unix, windows}::fs::OpenOptionsExt` and implemented them for `fs_err::OpenOptions`
+* Improved compile times by converting arguments early and forwarding only a small number of types internally. There will be a slight performance hit only in the error case.
+* Reduced trait bounds on generics from `AsRef<Path> + Into<PathBuf>` to either `AsRef<Path>` or `Into<PathBuf>`, making the functions more general.
+
+## 2.4.0
+* Added `canonicalize`, `hard link`, `read_link`, `rename`, `symlink_metadata` and `soft_link`. ([#25](https://github.com/andrewhickman/fs-err/pull/25))
+* Added aliases to `std::path::Path` via extension trait ([#26](https://github.com/andrewhickman/fs-err/pull/26))
+* Added `OpenOptions` ([#27](https://github.com/andrewhickman/fs-err/pull/27))
+* Added `set_permissions` ([#28](https://github.com/andrewhickman/fs-err/pull/28))
+
+## 2.3.0
+* Added `create_dir` and `create_dir_all`. ([#19](https://github.com/andrewhickman/fs-err/pull/19))
+* Added `remove_file`, `remove_dir`, and `remove_dir_all`. ([#16](https://github.com/andrewhickman/fs-err/pull/16))
+
+## 2.2.0
+* Added `metadata`. ([#15](https://github.com/andrewhickman/fs-err/pull/15))
+
+## 2.1.0
+* Updated crate-level documentation. ([#8](https://github.com/andrewhickman/fs-err/pull/8))
+* Added `read_dir`, `ReadDir`, and `DirEntry`. ([#9](https://github.com/andrewhickman/fs-err/pull/9))
+
+## 2.0.1 (2020-02-22)
+* Added `copy`. ([#7](https://github.com/andrewhickman/fs-err/pull/7))
+
+## 2.0.0 (2020-02-19)
+* Removed custom error type in favor of `std::io::Error`. ([#2](https://github.com/andrewhickman/fs-err/pull/2))
+
+## 1.0.1 (2020-02-15)
+* Fixed bad documentation link in `Cargo.toml`.
+
+## 1.0.0 (2020-02-15)
+* No changes from 0.1.2.
+
+## 0.1.2 (2020-02-10)
+* Added `Error::cause` implementation for `fs_err::Error`.
+
+## 0.1.1 (2020-02-05)
+* Added wrappers for `std::fs::*` functions.
+
+## 0.1.0 (2020-02-02)
+* Initial release, containing a wrapper around `std::fs::File`.